aboutsummaryrefslogtreecommitdiffstats
path: root/misc/astrolog/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-12-20 05:01:10 +0800
committerpawel <pawel@FreeBSD.org>2011-12-20 05:01:10 +0800
commite3a817946c13341907d344442af16531f905eb52 (patch)
tree6659054ed10b3709ecbf4bdc505597799df16f1b /misc/astrolog/Makefile
parent9a5a1a64cf33a5c97a52059ce0b0d3ca563d0c54 (diff)
downloadfreebsd-ports-gnome-e3a817946c13341907d344442af16531f905eb52.tar.gz
freebsd-ports-gnome-e3a817946c13341907d344442af16531f905eb52.tar.zst
freebsd-ports-gnome-e3a817946c13341907d344442af16531f905eb52.zip
- Fix build with WITHOUT_X11=true [1]
- Support NOPORTDOCS - Fix portlint warnings PR: ports/163093 [1] Submitted by: Christian Gusenbauer <c47g@gmx.at> [1]
Diffstat (limited to 'misc/astrolog/Makefile')
-rw-r--r--misc/astrolog/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/misc/astrolog/Makefile b/misc/astrolog/Makefile
index 52d28de2d0d1..22f57c239bd0 100644
--- a/misc/astrolog/Makefile
+++ b/misc/astrolog/Makefile
@@ -14,13 +14,14 @@ PORTREVISION= 11
CATEGORIES= misc
MASTER_SITES= http://www.astrolog.org/ftp/ephem/:ephem \
http://www.astrolog.org/ftp/:dist
-EXTRACT_ONLY= ast54unx.shr
-EPHEM= ephemall.zip
DISTFILES= ${EXTRACT_ONLY}:dist ${EPHEM}:ephem
+EXTRACT_ONLY= ast54unx.shr
MAINTAINER= ports@FreeBSD.org
COMMENT= An astrology program for X11 and alpha-numeric terminals
+EPHEM= ephemall.zip
+
USE_ZIP= yes
USE_DOS2UNIX= ephem/EPHINDEX.TXT
.if !defined(WITHOUT_X11)
@@ -34,6 +35,8 @@ DIST_SUBDIR= astrolog
ALL_TARGET= astrolog
NO_WRKSUBDIR= yes
+DOCS= Helpfile.540 Update.540 README.540
+
post-extract:
-@${MKDIR} ${WRKDIR}/ephem
${UNZIP_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EPHEM} -d ${WRKDIR}/ephem
@@ -52,13 +55,12 @@ do-install:
${INSTALL_DATA} astrolog.dat ${PREFIX}/lib/astrolog; \
fi
cd ${WRKSRC} && ${INSTALL_PROGRAM} astrolog ${PREFIX}/bin
- -@${MKDIR} ${PREFIX}/share/doc/astrolog
- cd ${WRKSRC} && \
- ${INSTALL_DATA} Helpfile.540 ${PREFIX}/share/doc/astrolog
- cd ${WRKSRC} && \
- ${INSTALL_DATA} Update.540 ${PREFIX}/share/doc/astrolog
- cd ${WRKSRC} && \
- ${INSTALL_DATA} README.540 ${PREFIX}/share/doc/astrolog
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
@${ECHO_MSG}
@${ECHO_MSG} "See the file ${PREFIX}/share/doc/astrolog/Helpfile.540 for help"
@${ECHO_MSG} "and tune ${PREFIX}/lib/astrolog/astrolog.dat"