aboutsummaryrefslogtreecommitdiffstats
path: root/misc/astrolog/files
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-06-15 06:22:51 +0800
committerwg <wg@FreeBSD.org>2013-06-15 06:22:51 +0800
commit601e4ec76f471f85b2e6b57799f669ea739234d5 (patch)
tree63e1834a540480c792c56fed940666edaa3e9672 /misc/astrolog/files
parent4160e6f813a9581eed66f880e2d3e4e6158d623a (diff)
downloadfreebsd-ports-gnome-601e4ec76f471f85b2e6b57799f669ea739234d5.tar.gz
freebsd-ports-gnome-601e4ec76f471f85b2e6b57799f669ea739234d5.tar.zst
freebsd-ports-gnome-601e4ec76f471f85b2e6b57799f669ea739234d5.zip
misc/astrolog: fix build with clang
- Fix build with clang - WITHOUT_X11 -> PORT_OPTIONS:MX11 - Use PORTDOCS instead of pkg-plist - Simplify docs install commands Approved by: culot / jpaetzel (mentors, implicit)
Diffstat (limited to 'misc/astrolog/files')
-rw-r--r--misc/astrolog/files/patch-ac27
1 files changed, 19 insertions, 8 deletions
diff --git a/misc/astrolog/files/patch-ac b/misc/astrolog/files/patch-ac
index 48b0f839bf0e..d0fec280a4c3 100644
--- a/misc/astrolog/files/patch-ac
+++ b/misc/astrolog/files/patch-ac
@@ -1,15 +1,17 @@
---- astrolog.c.orig 1998-12-23 23:29:03.000000000 +0300
-+++ astrolog.c 2007-06-26 15:44:04.000000000 +0400
-@@ -35,6 +35,7 @@
- ** Last code change made 12/20/1998.
+diff --git astrolog.c astrolog.c
+index 5a26c68..8294d3e 100644
+--- astrolog.c
++++ astrolog.c
+@@ -38,6 +38,7 @@
+ ** Modifications from version 5.40 to 5.41 are by Alois Treindl.
*/
+#include <ctype.h>
#include "astrolog.h"
-@@ -234,7 +235,7 @@
- char *pch = szLine;
+@@ -255,7 +256,7 @@ byte **argv;
+ byte *pch = szLine;
/* Split the entered line up into its individual switch strings. */
- while (*pch >= ' ' || *pch == chTab) {
@@ -17,7 +19,7 @@
if (*pch == ' ' || *pch == chTab) {
if (fSpace)
/* Skip over the current run of spaces between strings. */
-@@ -1146,8 +1147,18 @@
+@@ -1470,8 +1471,18 @@ byte **argv;
case 'z':
if (ch1 == '0') {
if (argc <= 1 || RParseSz(argv[1], pmZon) == rLarge) {
@@ -38,7 +40,7 @@
SS = us.dstDef = i ? 1.0 : 0.0;
} else {
SS = us.dstDef = RParseSz(argv[1], pmZon);
-@@ -1232,13 +1243,39 @@
+@@ -1556,13 +1567,39 @@ byte **argv;
return fFalse;
}
ciCore.nam = SzPersist(argv[1]);
@@ -81,3 +83,12 @@
ZZ = us.zonDef = RParseSz(argv[1], pmZon);
if (!FValidZon(us.zonDef)) {
ErrorValR("z", us.zonDef);
+@@ -2213,7 +2250,7 @@ byte **argv;
+ #ifdef SWITCHES
+ void main(argc, argv)
+ int argc;
+-byte **argv;
++char **argv;
+ {
+ #else
+ void main()