aboutsummaryrefslogtreecommitdiffstats
path: root/misc/bb/Makefile
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-03-25 12:30:31 +0800
committereadler <eadler@FreeBSD.org>2013-03-25 12:30:31 +0800
commitb188c769f2650f1a4c596b60d43f25ba20eed016 (patch)
treee9502ec9d580c1cb296d2b6e887c07a0737f2b7c /misc/bb/Makefile
parent6441d65203b3635b4c310c9e76e9296880cb7826 (diff)
downloadfreebsd-ports-gnome-b188c769f2650f1a4c596b60d43f25ba20eed016.tar.gz
freebsd-ports-gnome-b188c769f2650f1a4c596b60d43f25ba20eed016.tar.zst
freebsd-ports-gnome-b188c769f2650f1a4c596b60d43f25ba20eed016.zip
Cleanup unmaintained ports in the misc category:
- Trim Header - Convert to OptionsNG - Prefer DISTNAME to DISTFILES - Reorder variables - Fix comments (don't include leading article) - @unexec rm must not cause failure - Tabs, not spaces - Single space for WWW - Pet portlint - etc. In a few cases the option DOCS was used to control installation into EXAMPLEDIR. I opted to keep the existing logic of the port in these cases. Reviewed by: koobs, ashish
Diffstat (limited to 'misc/bb/Makefile')
-rw-r--r--misc/bb/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/misc/bb/Makefile b/misc/bb/Makefile
index 82406aa3c7a4..8a5923899782 100644
--- a/misc/bb/Makefile
+++ b/misc/bb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bb
-# Date created: 22 June 1998
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= bb
PORTVERSION= 1.3.r1
@@ -25,12 +21,14 @@ PORTDOCS= README
PLIST_FILES= bin/bb share/bb/bb.s3m share/bb/bb2.s3m share/bb/bb3.s3m
PLIST_DIRS= share/bb
+.include <bsd.port.options.mk>
+
pre-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -E -e "s@#include +<malloc.h>@#include <stdlib.h>@g" \
-e 's, REGISTERS \(3\),,g'
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif