aboutsummaryrefslogtreecommitdiffstats
path: root/misc/boxes/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-04-22 17:00:37 +0800
committervs <vs@FreeBSD.org>2005-04-22 17:00:37 +0800
commit6162180bcee7796d0e1f1a676d0a4392b79b31a9 (patch)
treedbd4c15f3593bb03e45eb95800a21293e8d291ab /misc/boxes/Makefile
parent02ded54ff1b80fda6a03ecf7a3f46f62830ab5d1 (diff)
downloadfreebsd-ports-gnome-6162180bcee7796d0e1f1a676d0a4392b79b31a9.tar.gz
freebsd-ports-gnome-6162180bcee7796d0e1f1a676d0a4392b79b31a9.tar.zst
freebsd-ports-gnome-6162180bcee7796d0e1f1a676d0a4392b79b31a9.zip
- Fix runtime error by regenerating path in config.h
- Use MAKE_ARGS instead of patches
Diffstat (limited to 'misc/boxes/Makefile')
-rw-r--r--misc/boxes/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/misc/boxes/Makefile b/misc/boxes/Makefile
index 36c2bdf5fe0d..99910b39b93d 100644
--- a/misc/boxes/Makefile
+++ b/misc/boxes/Makefile
@@ -21,12 +21,15 @@ MAN1= boxes.1
USE_GMAKE= yes
USE_BISON= yes
ALL_TARGET= boxes
-MAKE_ARGS= GLOBALCONF=${GLOBALCONF} CFLAGS_ADDTL="${CFLAGS}"
+MAKE_ARGS= CC="${CC}" GLOBALCONF=${GLOBALCONF} CFLAGS="${CFLAGS} -ansi -I. -Iregexp"
GLOBALCONF= ${DATADIR}/boxes-config
PLIST_FILES= bin/boxes share/boxes/boxes-config
PLIST_DIRS= share/boxes
+do-configure:
+ ${RM} ${WRKSRC}/src/boxes.h ${WRKSRC}/doc/boxes.1
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/boxes ${PREFIX}/bin
${MKDIR} ${DATADIR}