aboutsummaryrefslogtreecommitdiffstats
path: root/misc/buffer/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-12-14 01:33:18 +0800
committerlioux <lioux@FreeBSD.org>2005-12-14 01:33:18 +0800
commit60da8ab364efbb6e7e33e5339b2ed9aa6b0b1b92 (patch)
tree6cf40faf5205e2014bf709b72a5dfba82fd4b96a /misc/buffer/Makefile
parent6f95b25b03499cb53c7f2aa6c214743285cf7b05 (diff)
downloadfreebsd-ports-gnome-60da8ab364efbb6e7e33e5339b2ed9aa6b0b1b92.tar.gz
freebsd-ports-gnome-60da8ab364efbb6e7e33e5339b2ed9aa6b0b1b92.tar.zst
freebsd-ports-gnome-60da8ab364efbb6e7e33e5339b2ed9aa6b0b1b92.zip
o Update to 1.19
o Add several patches from Gentoo portage CVS Approved by: maintainer (thanks jonny) Obtained from: Gentoo portage CVS
Diffstat (limited to 'misc/buffer/Makefile')
-rw-r--r--misc/buffer/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/misc/buffer/Makefile b/misc/buffer/Makefile
index 9eafc6832a9f..c006aed408d5 100644
--- a/misc/buffer/Makefile
+++ b/misc/buffer/Makefile
@@ -6,17 +6,27 @@
#
PORTNAME= buffer
-PORTVERSION= 1.17.1
+PORTVERSION= 1.19
CATEGORIES= misc
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= steve
+MASTER_SITES= ${MASTER_SITE_GENTOO} \
+ http://www.mondorescue.org/download/MondoCD/TGZS/
+MASTER_SITE_SUBDIR= distfiles
+EXTRACT_SUFX= .tgz
MAINTAINER= jonny@jonny.eng.br
COMMENT= Buffer sporadic I/O for faster tape and pipe throughput
-USE_BZIP2= yes
-NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
+
MAN1= buffer.1
PLIST_FILES= bin/buffer
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|^(CC[[:space:]]*=).*$$|\1${CC}|' \
+ -e 's|^(CFLAGS[[:space:]]*=).*$$|\1${CFLAGS}|' \
+ -e 's|^(INSTBIN[[:space:]]*=).*$$|\1${PREFIX}/bin|' \
+ -e 's|^(INSTMAN[[:space:]]*=).*$$|\1${MAN1PREFIX}/man/man1|' \
+ ${WRKSRC}/Makefile
+
.include <bsd.port.mk>