aboutsummaryrefslogtreecommitdiffstats
path: root/misc/clpbar
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-31 08:12:48 +0800
committeradamw <adamw@FreeBSD.org>2014-07-31 08:12:48 +0800
commit5a063a75ad4e17ddf74d393b21e3e1465fa2e372 (patch)
treed1c6935645e6a55b3fdaa56aad07025fe44c8073 /misc/clpbar
parent0c7c2679dac59be62c82e31338cd1bdbdcaf33d8 (diff)
downloadfreebsd-ports-gnome-5a063a75ad4e17ddf74d393b21e3e1465fa2e372.tar.gz
freebsd-ports-gnome-5a063a75ad4e17ddf74d393b21e3e1465fa2e372.tar.zst
freebsd-ports-gnome-5a063a75ad4e17ddf74d393b21e3e1465fa2e372.zip
Actually, this is only necessary on 32-bit systems. This is probably also
not the most graceful way to accomplish this.
Diffstat (limited to 'misc/clpbar')
-rw-r--r--misc/clpbar/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/misc/clpbar/Makefile b/misc/clpbar/Makefile
index 89d1287c6929..2ddcc55a16d0 100644
--- a/misc/clpbar/Makefile
+++ b/misc/clpbar/Makefile
@@ -13,9 +13,14 @@ COMMENT= Command Line Progress Bar
WRKSRC= ${WRKDIR}/bar-${PORTVERSION}
GNU_CONFIGURE= yes
MAKE_ARGS+= CFLAGS+="${CFLAGS}"
-CONFIGURE_ARGS= --disable-use-m64
PLIST_FILES= bin/bar \
man/man1/bar.1.gz
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if empty(ARCH:M*64)
+CONFIGURE_ARGS= --disable-use-m64
+.endif
+
+.include <bsd.port.post.mk>