aboutsummaryrefslogtreecommitdiffstats
path: root/misc/compat3x
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-08-13 12:32:06 +0800
committerknu <knu@FreeBSD.org>2001-08-13 12:32:06 +0800
commit47db13251b4fcc80b43c1029cd82e5976c1446fb (patch)
tree22e10367f68cf4077c45ec48e2eaa92de433706d /misc/compat3x
parent716a0b77318ea05ae9670c170d11f9b12220c931 (diff)
downloadfreebsd-ports-gnome-47db13251b4fcc80b43c1029cd82e5976c1446fb.tar.gz
freebsd-ports-gnome-47db13251b4fcc80b43c1029cd82e5976c1446fb.tar.zst
freebsd-ports-gnome-47db13251b4fcc80b43c1029cd82e5976c1446fb.zip
Add compat22, compat3x and compat4x. These packages allow you to
install the compat libraries on your system, so you can use legacy binaries that depend on them. PR: ports/29371 Submitted by: Scot W. Hetzel <hetzels@westbend.net> Altered by: knu
Diffstat (limited to 'misc/compat3x')
-rw-r--r--misc/compat3x/Makefile48
-rw-r--r--misc/compat3x/distinfo6
-rw-r--r--misc/compat3x/pkg-comment1
-rw-r--r--misc/compat3x/pkg-descr2
-rw-r--r--misc/compat3x/pkg-plist24
5 files changed, 81 insertions, 0 deletions
diff --git a/misc/compat3x/Makefile b/misc/compat3x/Makefile
new file mode 100644
index 000000000000..3aae1f19c0fb
--- /dev/null
+++ b/misc/compat3x/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: compat3x libraries
+# Date created: 01 Aug 2001
+# Whom: Scot W. Hetzel
+#
+# $FreeBSD$
+#
+
+PORTNAME= compat3x
+PORTVERSION= 4.3
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_FREEBSD_ORG}
+MASTER_SITE_SUBDIR= releases/${ARCH}/${PORTVERSION}-RELEASE/${PORTNAME}
+PKGNAMESUFFIX= -${ARCH}
+DISTFILES= ${PORTNAME}.aa \
+ ${PORTNAME}.ab \
+ ${PORTNAME}.ac \
+ ${PORTNAME}.ad \
+ ${PORTNAME}.ae \
+ ${PORTNAME}.af
+DIST_SUBDIR= ${ARCH}/${PORTVERSION}
+
+MAINTAINER= hetzels@westbend.net
+
+ONLY_FOR_ARCHS= i386
+
+PREFIX?= /usr
+
+WRKSRC= ${WRKDIR}/usr/lib/compat
+NO_MTREE= yes
+NO_BUILD= yes
+
+TARGET_DIR= ${PREFIX}/lib/compat
+
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/lib/compat
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ cd ${_DISTDIR} && ${CAT} ${DISTFILES} | ${TAR} -xzf - -C ${WRKDIR}
+ ${MV} ${WRKSRC}/libc_r.so.4 ${WRKSRC}/libc_r.so.4.compat3x
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/* ${TARGET_DIR}/
+ if [ ! -e ${TARGET_DIR}/libc_r.so.4.compat4x ]; then \
+ ${LN} -sf ${TARGET_DIR}/libc_r.so.4.compat3x ${TARGET_DIR}/libc_r.so.4; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/misc/compat3x/distinfo b/misc/compat3x/distinfo
new file mode 100644
index 000000000000..0d522a851f4e
--- /dev/null
+++ b/misc/compat3x/distinfo
@@ -0,0 +1,6 @@
+MD5 (i386/4.3/compat3x.aa) = 3b910273f01d53c34f049fdcb24e81fe
+MD5 (i386/4.3/compat3x.ab) = 89b966359f5c42b54ecd946d12783616
+MD5 (i386/4.3/compat3x.ac) = 42627a60446f2695f49438d0a989ac81
+MD5 (i386/4.3/compat3x.ad) = 0e2c7ecededae1464c8eff7765d2fa45
+MD5 (i386/4.3/compat3x.ae) = a2aba322ce46ee6f56a74f420e09cac1
+MD5 (i386/4.3/compat3x.af) = 5c468e681b6efb9a0ea7faf7187535bc
diff --git a/misc/compat3x/pkg-comment b/misc/compat3x/pkg-comment
new file mode 100644
index 000000000000..6a65bd0be384
--- /dev/null
+++ b/misc/compat3x/pkg-comment
@@ -0,0 +1 @@
+A convenience package to install the compat3x libraries
diff --git a/misc/compat3x/pkg-descr b/misc/compat3x/pkg-descr
new file mode 100644
index 000000000000..e9fecf5361ab
--- /dev/null
+++ b/misc/compat3x/pkg-descr
@@ -0,0 +1,2 @@
+This package allows you to install the compat3x libraries on your
+system, so you can use legacy binaries that depend on them.
diff --git a/misc/compat3x/pkg-plist b/misc/compat3x/pkg-plist
new file mode 100644
index 000000000000..b82a1d8bfd44
--- /dev/null
+++ b/misc/compat3x/pkg-plist
@@ -0,0 +1,24 @@
+lib/compat/libalias.so.3
+lib/compat/libc.so.3
+lib/compat/libc_r.so.3
+@unexec if [ -e %B/libc_r.so.4.compat4x ]; then ln -sf %B/libc_r.so.4.compat4x %B/libc_r.so.4; else rm %B/libc_r.so.4; fi
+lib/compat/libc_r.so.4.compat3x
+@exec if [ ! -e %B/libc_r.so.4.compat4x ]; then ln -sf %B/%f %B/libc_r.so.4; fi
+lib/compat/libcurses.so.2
+lib/compat/libdialog.so.3
+lib/compat/libedit.so.2
+lib/compat/libf2c.so.2
+lib/compat/libfetch.so.1
+lib/compat/libftpio.so.4
+lib/compat/libg++.so.4
+lib/compat/libhistory.so.3
+lib/compat/libmytinfo.so.2
+lib/compat/libncurses.so.3
+lib/compat/libreadline.so.3
+lib/compat/libss.so.2
+lib/compat/libstdc++.so.2
+lib/compat/libtermcap.so.2
+lib/compat/libutil.so.2
+lib/compat/libvgl.so.1
+lib/compat/libwrap.so.2
+lib/compat/libxpg4.so.2