aboutsummaryrefslogtreecommitdiffstats
path: root/misc/compat4x
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-08-16 02:17:47 +0800
committerknu <knu@FreeBSD.org>2001-08-16 02:17:47 +0800
commit474a2846a578e20f9ef31d14b358958f59430d0a (patch)
tree7605398d29619780598e7ad7648d064f105ed405 /misc/compat4x
parent98bbe0e517e60bcbe4b66281ace89810dc1bc21e (diff)
downloadfreebsd-ports-gnome-474a2846a578e20f9ef31d14b358958f59430d0a.tar.gz
freebsd-ports-gnome-474a2846a578e20f9ef31d14b358958f59430d0a.tar.zst
freebsd-ports-gnome-474a2846a578e20f9ef31d14b358958f59430d0a.zip
Change PREFIX from /usr to the default not to harm bento.
Prepare rc.d scripts that do ldconfig on startup, because $PREFIX/lib/compat and $PREFIX/lib/compat/aout are no longer included in the default $ldconfig_paths and $ldconfig_paths_aout, respectively.
Diffstat (limited to 'misc/compat4x')
-rw-r--r--misc/compat4x/Makefile14
-rw-r--r--misc/compat4x/pkg-plist2
2 files changed, 9 insertions, 7 deletions
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
index b5f948224e3c..e5ab458ba8ac 100644
--- a/misc/compat4x/Makefile
+++ b/misc/compat4x/Makefile
@@ -7,6 +7,7 @@
PORTNAME= compat4x
PORTVERSION= ${COMPAT4X_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${COMPAT4X_MASTER_SITES}
PKGNAMESUFFIX= -${ARCH}
@@ -15,21 +16,14 @@ DIST_SUBDIR= ${ARCH}/${PORTVERSION}
MAINTAINER= hetzels@westbend.net
-PREFIX?= /usr
-
WRKSRC= ${WRKDIR}/usr/lib/compat
NO_MTREE= yes
-NO_BUILD= yes
TARGET_DIR= ${PREFIX}/lib/compat
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/compat
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "does damage to bento cluster"
-.endif
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
@@ -66,10 +60,16 @@ do-extract:
${MV} ${WRKSRC}/libc_r.so.4 ${WRKSRC}/libc_r.so.4.compat4x
.endif
+do-build:
+ @( ${ECHO} '#!/bin/sh'; ${ECHO} '${LDCONFIG} -m ${LDCONFIG_RUNLIST}'; \
+ ) > ${WRKDIR}/000.${PORTNAME}.sh
+
do-install:
+ ${MKDIR} ${TARGET_DIR}
${INSTALL_DATA} ${WRKSRC}/* ${TARGET_DIR}/
.if ${OSVERSION} >= 500000
${LN} -sf ${TARGET_DIR}/libc_r.so.4.compat4x ${TARGET_DIR}/libc_r.so.4
.endif
+ ${INSTALL_SCRIPT} ${WRKDIR}/000.${PORTNAME}.sh ${PREFIX}/etc/rc.d/
.include <bsd.port.post.mk>
diff --git a/misc/compat4x/pkg-plist b/misc/compat4x/pkg-plist
index e5f6e048bfef..d64e84aa6478 100644
--- a/misc/compat4x/pkg-plist
+++ b/misc/compat4x/pkg-plist
@@ -1,6 +1,8 @@
+etc/rc.d/000.compat4x.sh
%%CURRENT_ONLY:%%lib/compat/libc.so.4
%%CURRENT_ONLY:%%@unexec if [ -e %B/libc_r.so.4.compat3x ]; then ln -sf %B/libc_r.so.4.compat3x %B/libc_r.so.4; else rm %B/libc_r.so.4; fi
%%CURRENT_ONLY:%%lib/compat/libc_r.so.4.compat4x
%%CURRENT_ONLY:%%@exec ln -sf %B/%f %B/libc_r.so.4
lib/compat/libcrypto.so.1
lib/compat/libssl.so.1
+@unexec rmdir %D/lib/compat 2>/dev/null || true