aboutsummaryrefslogtreecommitdiffstats
path: root/misc/diary-hercules/Makefile
diff options
context:
space:
mode:
authorjmelo <jmelo@FreeBSD.org>2006-05-19 02:40:19 +0800
committerjmelo <jmelo@FreeBSD.org>2006-05-19 02:40:19 +0800
commitd99dd13954110896764f8b16a081655de67dd33e (patch)
tree621fe75f04d3bcb566c02c8f449cf23c3df59f8f /misc/diary-hercules/Makefile
parentcaaf1ddaff74313a16434f6deecc98f994781c33 (diff)
downloadfreebsd-ports-gnome-d99dd13954110896764f8b16a081655de67dd33e.tar.gz
freebsd-ports-gnome-d99dd13954110896764f8b16a081655de67dd33e.tar.zst
freebsd-ports-gnome-d99dd13954110896764f8b16a081655de67dd33e.zip
- New port:
Hercules is a personal workout diary program for bodybuilders. Hercules written on Python with wxPython GUI library. To store data its use SQLite. PR: ports/96697 Submitted by: Andrew Pantyukhin <infofarmer@gmail.com> Approved by: mnag (mentor)
Diffstat (limited to 'misc/diary-hercules/Makefile')
-rw-r--r--misc/diary-hercules/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/misc/diary-hercules/Makefile b/misc/diary-hercules/Makefile
new file mode 100644
index 000000000000..46c2ac799c93
--- /dev/null
+++ b/misc/diary-hercules/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: diary-hercules
+# Date created: 2 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diary-hercules
+PORTVERSION= 0.0.3.2
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= hercules-${PORTVERSION}
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= A personal workout diary program for bodybuilders
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/wx-2.6-gtk2-unicode/wx/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython26-unicode \
+ ${PYTHON_SITELIBDIR}/sqlite/__init__.py:${PORTSDIR}/databases/py-PySQLite11
+
+USE_GETTEXT= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>