aboutsummaryrefslogtreecommitdiffstats
path: root/misc/display
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2005-12-15 20:54:25 +0800
committerroam <roam@FreeBSD.org>2005-12-15 20:54:25 +0800
commit0f47048193ef3987e2b56d048616da491e55ab63 (patch)
treeecdd0b32640c06ed8486eed039cff48ad1ba7979 /misc/display
parentf25fe1f743907850a27bb405b80c3587dd7db6a4 (diff)
downloadfreebsd-ports-gnome-0f47048193ef3987e2b56d048616da491e55ab63.tar.gz
freebsd-ports-gnome-0f47048193ef3987e2b56d048616da491e55ab63.tar.zst
freebsd-ports-gnome-0f47048193ef3987e2b56d048616da491e55ab63.zip
Update to display-1.2a, which incorporates our 8-bit character patch and
also unconditionally uses libncurses now. Honor ${STRIP}.
Diffstat (limited to 'misc/display')
-rw-r--r--misc/display/Makefile4
-rw-r--r--misc/display/distinfo6
-rw-r--r--misc/display/files/patch-aa10
-rw-r--r--misc/display/files/patch-ab19
4 files changed, 19 insertions, 20 deletions
diff --git a/misc/display/Makefile b/misc/display/Makefile
index 5d9637711156..106dc7aefac1 100644
--- a/misc/display/Makefile
+++ b/misc/display/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= display
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.2a
CATEGORIES= misc
MASTER_SITES= http://www.ipsmart.com/src/
EXTRACT_SUFX= .tgz
@@ -29,6 +28,7 @@ CONFLICTS= ImageMagick-[0-9]* goblin-*
.endif
CONFIGURE_ARGS+= --program-prefix=${DISPLAY_PROGRAM_PREFIX}
+CONFIGURE_ENV+= LDFLAGS="${STRIP}"
MAN1= ${DISPLAY_PROGRAM_PREFIX}display.1
PLIST_FILES= bin/${DISPLAY_PROGRAM_PREFIX}display
diff --git a/misc/display/distinfo b/misc/display/distinfo
index 4c5397045a32..6c86d8d869e8 100644
--- a/misc/display/distinfo
+++ b/misc/display/distinfo
@@ -1,3 +1,3 @@
-MD5 (display-1.2.tgz) = f39d53828bb1c8d9cd6ab419a197e899
-SHA256 (display-1.2.tgz) = b3551a8df0e21bb034618517048fb72ec50efa820df96167dcbeed96fbf7cb73
-SIZE (display-1.2.tgz) = 14839
+MD5 (display-1.2a.tgz) = 8f290fdc82e10cbc99d19a25cc790e65
+SHA256 (display-1.2a.tgz) = 14fe882abff0425d9bd4042894923d027088797667fbb6b905f868a396f39b60
+SIZE (display-1.2a.tgz) = 29636
diff --git a/misc/display/files/patch-aa b/misc/display/files/patch-aa
index dd3156f827b2..96f0b3feb762 100644
--- a/misc/display/files/patch-aa
+++ b/misc/display/files/patch-aa
@@ -1,5 +1,5 @@
---- display.c.orig Mon Mar 26 10:03:42 2001
-+++ display.c Fri Mar 8 01:15:54 2002
+--- display.c.orig Thu Dec 15 14:29:14 2005
++++ display.c Thu Dec 15 14:29:58 2005
@@ -12,6 +12,7 @@
#include <signal.h>
#include <ctype.h>
@@ -27,14 +27,12 @@
for(i = 0; i < 128; i++)
{
-@@ -90,8 +90,8 @@
+@@ -90,7 +90,7 @@
void display()
{
- FILE *fp, *popen();
-- char ch;
+ FILE *fp;
-+ int ch;
+ int ch;
char *dt;
time_t tnow;
- int nlines;
diff --git a/misc/display/files/patch-ab b/misc/display/files/patch-ab
index 4f1a91044405..4888b3600a14 100644
--- a/misc/display/files/patch-ab
+++ b/misc/display/files/patch-ab
@@ -1,29 +1,30 @@
---- Makefile.in.orig Tue Nov 28 13:17:40 2000
-+++ Makefile.in Fri Mar 8 01:17:24 2002
-@@ -2,10 +2,13 @@
+--- Makefile.in.orig Wed Dec 14 05:50:47 2005
++++ Makefile.in Thu Dec 15 14:49:37 2005
+@@ -2,10 +2,14 @@
# vix 15dec86 [stolen from 'which']
# start changing
-CFLAGS = -O
-DEST_DIR = /usr/local/bin
--CURSES_LIBS = -lcurses -ltermcap
--MAN_DIR = /usr/local/man/man1
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+CC = @CC@
+DEST_DIR = @bindir@
-+CURSES_LIBS = -lncurses
+ CURSES_LIBS = -lncurses
+-MAN_DIR = /usr/local/man/man1
+MAN_DIR = @mandir@/man1
MAN_SUFFIX = 1
SHAR_ARGS = -b -c -v
# stop changing
-@@ -16,7 +19,7 @@
+@@ -16,8 +20,7 @@
all : display
display : display.c
- cc $(CFLAGS) -o $@ display.c $(CURSES_LIBS)
-+ $(CC) $(CFLAGS) -o $@ display.c $(CURSES_LIBS)
- strip display
+- strip display
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ display.c $(CURSES_LIBS)
install : all
+ mv display $(DEST_DIR)