aboutsummaryrefslogtreecommitdiffstats
path: root/misc/display
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-03-20 08:09:25 +0800
committermat <mat@FreeBSD.org>2014-03-20 08:09:25 +0800
commitfd1b3e6fd6f6262e15857f3ee8185930afa499e1 (patch)
tree6995a0c30a91ec65292740d393d6698891572ba7 /misc/display
parent97c4597ed11c5ed24b2439412250373aa98300c1 (diff)
downloadfreebsd-ports-gnome-fd1b3e6fd6f6262e15857f3ee8185930afa499e1.tar.gz
freebsd-ports-gnome-fd1b3e6fd6f6262e15857f3ee8185930afa499e1.tar.zst
freebsd-ports-gnome-fd1b3e6fd6f6262e15857f3ee8185930afa499e1.zip
- Convert to staging
- Cleanup unneeded bits in the Makefile - Patch a bit more to fix compiler warnings - While there, rename patches to follow makepatch naming. Sponsored by: Absolight
Diffstat (limited to 'misc/display')
-rw-r--r--misc/display/Makefile11
-rw-r--r--misc/display/files/patch-Makefile.in (renamed from misc/display/files/patch-ab)0
-rw-r--r--misc/display/files/patch-display.c (renamed from misc/display/files/patch-aa)25
3 files changed, 22 insertions, 14 deletions
diff --git a/misc/display/Makefile b/misc/display/Makefile
index c32687dbf2db..f4897a389ed0 100644
--- a/misc/display/Makefile
+++ b/misc/display/Makefile
@@ -15,7 +15,6 @@ GNU_CONFIGURE= yes
DISPLAY_PROGRAM_PREFIX?=
.if empty(DISPLAY_PROGRAM_PREFIX)
-NO_STAGE= yes
pre-everything::
@${ECHO_MSG} "NOTE: You may set DISPLAY_PROGRAM_PREFIX to change the name of the 'display'"
@${ECHO_MSG} "utility so that it does not conflict with similarly named files from"
@@ -24,14 +23,10 @@ pre-everything::
CONFLICTS= ImageMagick-[0-9]* goblin-*
.endif
-CONFIGURE_ARGS+= --program-prefix=${DISPLAY_PROGRAM_PREFIX}
-LDFLAGS+= ${STRIP}
-
-MAN1= ${DISPLAY_PROGRAM_PREFIX}display.1
-PLIST_FILES= bin/${DISPLAY_PROGRAM_PREFIX}display
+PLIST_FILES= bin/${DISPLAY_PROGRAM_PREFIX}display man/man1/${DISPLAY_PROGRAM_PREFIX}display.1.gz
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/display ${PREFIX}/bin/${DISPLAY_PROGRAM_PREFIX}display
- ${INSTALL_MAN} ${WRKSRC}/display.man ${MANPREFIX}/man/man1/${DISPLAY_PROGRAM_PREFIX}display.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/display ${STAGEDIR}${PREFIX}/bin/${DISPLAY_PROGRAM_PREFIX}display
+ ${INSTALL_MAN} ${WRKSRC}/display.man ${STAGEDIR}${MANPREFIX}/man/man1/${DISPLAY_PROGRAM_PREFIX}display.1
.include <bsd.port.mk>
diff --git a/misc/display/files/patch-ab b/misc/display/files/patch-Makefile.in
index 4888b3600a14..4888b3600a14 100644
--- a/misc/display/files/patch-ab
+++ b/misc/display/files/patch-Makefile.in
diff --git a/misc/display/files/patch-aa b/misc/display/files/patch-display.c
index 96f0b3feb762..f19be20822fa 100644
--- a/misc/display/files/patch-aa
+++ b/misc/display/files/patch-display.c
@@ -1,14 +1,17 @@
---- display.c.orig Thu Dec 15 14:29:14 2005
-+++ display.c Thu Dec 15 14:29:58 2005
-@@ -12,6 +12,7 @@
+--- ./display.c.orig 2005-12-14 04:40:15.000000000 +0100
++++ ./display.c 2014-03-20 01:01:07.000000000 +0100
+@@ -12,6 +12,10 @@
#include <signal.h>
#include <ctype.h>
#include <time.h>
+#include <stdio.h>
++#include <unistd.h>
++#include <stdlib.h>
++#include <string.h>
#define DEFAULT_DELAY 5
#define DISPLAY_VERSION "1.2"
-@@ -19,6 +20,8 @@
+@@ -19,17 +23,16 @@
static char *Command;
static int Delay;
@@ -17,7 +20,9 @@
char lt[128];
int ntimes;
-@@ -27,9 +30,6 @@
+-main(argc, argv)
++int main(argc, argv)
+ int argc;
char *argv[];
{
int i, c;
@@ -27,7 +32,7 @@
for(i = 0; i < 128; i++)
{
-@@ -90,7 +90,7 @@
+@@ -90,7 +93,7 @@
void display()
{
@@ -36,3 +41,11 @@
int ch;
char *dt;
time_t tnow;
+@@ -133,7 +136,6 @@
+ int argc;
+ char *argv[];
+ {
+- extern void usage();
+ auto int argn,
+ delay_found;
+