aboutsummaryrefslogtreecommitdiffstats
path: root/misc/e2fsprogs-libblkid/Makefile
diff options
context:
space:
mode:
authortimur <timur@FreeBSD.org>2007-10-02 23:50:56 +0800
committertimur <timur@FreeBSD.org>2007-10-02 23:50:56 +0800
commit2840cec2f1defe082d61424a302c365407a9e174 (patch)
treed36115d3e1718d7e0aad81cb9bc2e194ccc78dc8 /misc/e2fsprogs-libblkid/Makefile
parenta580c79e7e0cadee4f4b058e2e9571f117a01d75 (diff)
downloadfreebsd-ports-gnome-2840cec2f1defe082d61424a302c365407a9e174.tar.gz
freebsd-ports-gnome-2840cec2f1defe082d61424a302c365407a9e174.tar.zst
freebsd-ports-gnome-2840cec2f1defe082d61424a302c365407a9e174.zip
A new slave port of the blkid library from the sysutils/e2fsprogs.
PR: ports/116231 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer) Approved by: shaun (mentor)
Diffstat (limited to 'misc/e2fsprogs-libblkid/Makefile')
-rw-r--r--misc/e2fsprogs-libblkid/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/misc/e2fsprogs-libblkid/Makefile b/misc/e2fsprogs-libblkid/Makefile
new file mode 100644
index 000000000000..03045e65e283
--- /dev/null
+++ b/misc/e2fsprogs-libblkid/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: e2fsprogs-libblkid
+# Date created: 2007-09-07
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+#
+# $FreeBSD$
+#
+# set PORTREVISION to avoid override by master port
+
+PORTREVISION= 0
+CATEGORIES= misc devel
+PKGNAMESUFFIX= -libblkid
+
+COMMENT= A blkid library from e2fsprogs package
+
+LIB_DEPENDS= uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
+
+CONFIGURE_ARGS= --enable-elf-shlibs
+
+WITHOUT_NLS= yes
+MASTERDIR= ${.CURDIR}/../../sysutils/e2fsprogs
+MAKE_ARGS= LIB_SUBDIRS=lib/blkid
+USE_LDCONFIG= yes
+ALL_TARGET= libs
+INSTALL_TARGET= install install-shlibs
+INSTALL_WRKSRC= ${WRKSRC}/lib/blkid
+
+MAN3= libblkid.3
+
+PKGDIR= ${.CURDIR}
+
+pre-build:
+ ${MKDIR} ${WRKSRC}/lib/blkid/elfshared
+
+post-build:
+ cd ${WRKSRC}/lib/uuid && ${MAKE}
+ cd ${INSTALL_WRKSRC} && ${MAKE} check
+
+.include "${MASTERDIR}/Makefile"