aboutsummaryrefslogtreecommitdiffstats
path: root/misc/esniper/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-04-12 05:10:03 +0800
committerpav <pav@FreeBSD.org>2005-04-12 05:10:03 +0800
commit1131600d9a05f5fb15c67aa8741b1d074caf0d9f (patch)
tree0deb96a187226d86e6dd1b24f30712c9858dc9d2 /misc/esniper/Makefile
parentd6bfbd7306c730abede76056906702e253b378a6 (diff)
downloadfreebsd-ports-gnome-1131600d9a05f5fb15c67aa8741b1d074caf0d9f.tar.gz
freebsd-ports-gnome-1131600d9a05f5fb15c67aa8741b1d074caf0d9f.tar.zst
freebsd-ports-gnome-1131600d9a05f5fb15c67aa8741b1d074caf0d9f.zip
A new port for esniper (http://esniper.sourceforge.net/), a lightweight
eBay snipe tool. PR: ports/79771 Submitted by: Lewis Thompson <lewiz@compsoc.man.ac.uk>
Diffstat (limited to 'misc/esniper/Makefile')
-rw-r--r--misc/esniper/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/misc/esniper/Makefile b/misc/esniper/Makefile
new file mode 100644
index 000000000000..032195e96f8a
--- /dev/null
+++ b/misc/esniper/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: esniper
+# Date created: 10 April 2005
+# Whom: Lewis Thompson <lewiz@compsoc.man.ac.uk>
+#
+# $FreeBSD$
+
+PORTNAME= esniper
+DISTVERSION= 2-10-0
+CATEGORIES= misc net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lewiz@compsoc.man.ac.uk
+COMMENT= Lightweight tool for sniping ebay auctions
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+
+MAN1= esniper.1
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample_auction.txt ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample_config.txt ${EXAMPLESDIR}
+
+.include <bsd.port.mk>