aboutsummaryrefslogtreecommitdiffstats
path: root/misc/flyway
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-03-14 22:35:12 +0800
committerijliao <ijliao@FreeBSD.org>2002-03-14 22:35:12 +0800
commitb90bc00c68a6b3202a972fc7675149b21b847bba (patch)
treeca0f5221866ab6f568c128c39122c2c4b2f12a98 /misc/flyway
parent7a6117c79e6dba51e8dffd8136880698644462b4 (diff)
downloadfreebsd-ports-gnome-b90bc00c68a6b3202a972fc7675149b21b847bba.tar.gz
freebsd-ports-gnome-b90bc00c68a6b3202a972fc7675149b21b847bba.tar.zst
freebsd-ports-gnome-b90bc00c68a6b3202a972fc7675149b21b847bba.zip
add flyway 0.2.2
A VFR/IFR Route Planner for Pilots
Diffstat (limited to 'misc/flyway')
-rw-r--r--misc/flyway/Makefile32
-rw-r--r--misc/flyway/distinfo1
-rw-r--r--misc/flyway/pkg-comment1
-rw-r--r--misc/flyway/pkg-descr8
-rw-r--r--misc/flyway/pkg-plist19
5 files changed, 61 insertions, 0 deletions
diff --git a/misc/flyway/Makefile b/misc/flyway/Makefile
new file mode 100644
index 000000000000..db5529f694de
--- /dev/null
+++ b/misc/flyway/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: flyway
+# Date created: Mar 14, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= flyway
+PORTVERSION= 0.2.2
+CATEGORIES= misc python
+MASTER_SITES= http://www.xecu.net/dougbell/flyway/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/qt.py:${PORTSDIR}/x11-toolkits/py-qt
+
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PYTHON_SITELIBDIR}/${PORTNAME}
+ ${CP} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}/${PORTNAME}
+ ${CP} ${WRKSRC}/*.dat ${PYTHON_SITELIBDIR}/${PORTNAME}
+ @${LN} -sf ${PYTHON_SITELIBDIR}/${PORTNAME}/flyway.py ${PREFIX}/bin/flyway
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} ${WRKSRC}/README.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/flyway/distinfo b/misc/flyway/distinfo
new file mode 100644
index 000000000000..17b870bc36ed
--- /dev/null
+++ b/misc/flyway/distinfo
@@ -0,0 +1 @@
+MD5 (flyway-0.2.2.tar.gz) = a4eabec6da80935936f5000b7184252d
diff --git a/misc/flyway/pkg-comment b/misc/flyway/pkg-comment
new file mode 100644
index 000000000000..ede433474087
--- /dev/null
+++ b/misc/flyway/pkg-comment
@@ -0,0 +1 @@
+A VFR/IFR Route Planner for Pilots
diff --git a/misc/flyway/pkg-descr b/misc/flyway/pkg-descr
new file mode 100644
index 000000000000..0aee7635886b
--- /dev/null
+++ b/misc/flyway/pkg-descr
@@ -0,0 +1,8 @@
+Flyway allows the user to find and enter U.S. waypoints (airports, navaids,
+and fixes), then it calculates courses, wind corrections, and travel times.
+Information about the waypoints is provided (including frequencies, elevation,
+fuel availability, and runway descriptions). The route data can also be used
+to fill in an editable FAA Flight Plan form, and a very rough map of the
+route can be displayed.
+
+WWW: http://www.xecu.net/dougbell/flyway/
diff --git a/misc/flyway/pkg-plist b/misc/flyway/pkg-plist
new file mode 100644
index 000000000000..423a53768783
--- /dev/null
+++ b/misc/flyway/pkg-plist
@@ -0,0 +1,19 @@
+bin/flyway
+lib/%%PYTHON_VERSION%%/site-packages/flyway/apt.dat
+lib/%%PYTHON_VERSION%%/site-packages/flyway/fix.dat
+lib/%%PYTHON_VERSION%%/site-packages/flyway/flycore.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/flyway.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/helpview.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/nav.dat
+lib/%%PYTHON_VERSION%%/site-packages/flyway/option.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/optiondlg.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/printpreview.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/recentfiles.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/searchstr.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/textpaint.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/tmpcontrol.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/units.py
+lib/%%PYTHON_VERSION%%/site-packages/flyway/xpm.py
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/flyway
+%%PORTDOCS%%share/doc/flyway/README.html
+%%PORTDOCS%%@dirrm share/doc/flyway