aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gimp-help-en/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-06-15 04:47:50 +0800
committermakc <makc@FreeBSD.org>2010-06-15 04:47:50 +0800
commit27561b5c49bf07b86d952a313cb518d19c0da29c (patch)
tree08d2551105acf651753b44f979156c083b40aa46 /misc/gimp-help-en/Makefile
parent01ae6692974ba58b92c2c8ff23c81c05b7922978 (diff)
downloadfreebsd-ports-gnome-27561b5c49bf07b86d952a313cb518d19c0da29c.tar.gz
freebsd-ports-gnome-27561b5c49bf07b86d952a313cb518d19c0da29c.tar.zst
freebsd-ports-gnome-27561b5c49bf07b86d952a313cb518d19c0da29c.zip
Add new ports for GIMP Manual:
The GIMP User Manual is distributed as a set of HTML pages for use with the internal GIMP help browser or any web browser. WWW: http://docs.gimp.org/ PR: ports/145650, ports/145652 Submitted by: SimaMoto, RyoTa <liangtai.s4 at gmail.com>
Diffstat (limited to 'misc/gimp-help-en/Makefile')
-rw-r--r--misc/gimp-help-en/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/misc/gimp-help-en/Makefile b/misc/gimp-help-en/Makefile
new file mode 100644
index 000000000000..2ebfc317c1a3
--- /dev/null
+++ b/misc/gimp-help-en/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gimp-help
+# Date created: 9th April 2010
+# Whom: SimaMoto,RyoTa <liangtai.s4@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gimp-help
+PORTVERSION= 2.6.0
+CATEGORIES?= misc graphics
+MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
+ http://gimp.mirrors.hoobly.com/%SUBDIR%/ \
+ http://ftp.gwdg.de/pub/misc/grafik/gimp/%SUBDIR%/ \
+ http://www.mirrorservice.org/sites/ftp.gimp.org/pub/%SUBDIR%/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/%SUBDIR%,}
+MASTER_SITE_SUBDIR= gimp/help
+PKGNAMEPREFIX?= ${DOCLANG}-
+PKGNAMESUFFIX= -html
+DISTNAME= ${PORTNAME}-${PORTVERSION}${PKGNAMESUFFIX}-${DOCLANG}
+
+MAINTAINER= liangtai.s4@gmail.com
+COMMENT?= The GIMP User Manual in English
+
+USE_BZIP2= YES
+NO_BUILD= YES
+PLIST_SUB= GIMPDATA=${GIMPDATADIR:S,^${PREFIX}/,,} \
+ AMPLE=${AMPLE} DOCLANG=${DOCLANG}
+
+# Though this is document, to be used by the context help system
+# of GIMP. That's why this is not set PORTDOC.
+GIMPDATADIR?= ${PREFIX}/share/gimp
+DOCLANG?= en
+AMPLE?= ""
+
+do-install:
+ @ ${MKDIR} ${GIMPDATADIR}/help ; \
+ cd ${WRKDIR}/${PORTNAME}-2/html && \
+ ${COPYTREE_SHARE} ${DOCLANG} ${GIMPDATADIR}/help
+
+.include <bsd.port.mk>
d>kris2005-07-301-1/+1 * - Track the in-place distfile change [1], which looks like a version updatejylefort2005-07-303-22/+5 * Pass maintainership to last submittergarga2005-07-291-1/+1 * This port is scheduled for deletion on 2005-09-22 if it is still brokenkris2005-07-232-0/+4 * Upgrade to 0.0.7des2005-07-234-6/+14 * Upgrade to 5.64 and unbreak.thierry2005-07-213-10/+8 * Chase TK upgrade and unbreak.thierry2005-07-182-5/+13 * BROKEN: Does not buildkris2005-07-181-0/+2 * BROKEN: Size mismatchkris2005-07-091-0/+2 * BROKEN: Size mismatchkris2005-07-091-0/+2 * Update to version 3.3.19.novel2005-07-092-4/+4 * Upgrade to 1.2.4.thierry2005-07-047-13/+49 * Upgrade to 7.2.6, and don't mark broken on amd64.thierry2005-07-033-20/+52 * - Update to 3.3.18ahze2005-06-274-88/+86 * The tochnog port installs some plugins into a directory which is owned bynetchild2005-06-262-3/+11 * Chase dependency location (linux-gid) after my linux mega-patch.netchild2005-06-251-1/+2 * Mega-patch to cleanup the ports infrastructure regarding our linux bits:netchild2005-06-183-5/+4 * Update to 0.40.4.novel2005-06-173-8/+10 * Update to 20050609. Changes include:hrs2005-06-158-196/+264 * Graphical circuit design and simulation tool.des2005-06-126-0/+252 * change the libtool version to use from 1.3 to 1.5oliver2005-06-011-1/+1