aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gkrellm-helium/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-06 19:41:44 +0800
committeredwin <edwin@FreeBSD.org>2003-10-06 19:41:44 +0800
commit230fbe3087f7ca81df9c276a90957a984c066345 (patch)
tree5cdff1aa41c75ea90ffee331a3fc1cdbe1c37a81 /misc/gkrellm-helium/Makefile
parent9e3cc6e3b50205892b3a768e2cfeb1cf4f1ec8c1 (diff)
downloadfreebsd-ports-gnome-230fbe3087f7ca81df9c276a90957a984c066345.tar.gz
freebsd-ports-gnome-230fbe3087f7ca81df9c276a90957a984c066345.tar.zst
freebsd-ports-gnome-230fbe3087f7ca81df9c276a90957a984c066345.zip
new port: misc/gkrellm-helium, Prague thermometer
Tiny gkrellm plugin which read data from thermometer at Strahov, Prague. Probably useless for anyone not interested in Prague's weather. :) Tested on both stable and current. PR: ports/51162 Submitted by: Pav Lucistnik <pav@oook.cz>
Diffstat (limited to 'misc/gkrellm-helium/Makefile')
-rw-r--r--misc/gkrellm-helium/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/gkrellm-helium/Makefile b/misc/gkrellm-helium/Makefile
new file mode 100644
index 000000000000..8f373706ad6d
--- /dev/null
+++ b/misc/gkrellm-helium/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: gkrellm-helium
+# Date Created: 19 Apr 2003
+# Whom: Pav Lucistnik <pav@oook.cz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gkrellm-helium
+PORTVERSION= 2.1
+CATEGORIES= misc
+MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= pav@oook.cz
+COMMENT= GKrellM plugin reading data from helium thermometer at Strahov, Prague
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|/usr/local/lib/gkrellm2/plugins|${PREFIX}/libexec/gkrellm2/plugins|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|ulong|u_long|' ${WRKSRC}/*.c
+
+.include <bsd.port.mk>