aboutsummaryrefslogtreecommitdiffstats
path: root/misc/goblin/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-04-01 16:44:28 +0800
committerijliao <ijliao@FreeBSD.org>2003-04-01 16:44:28 +0800
commit15189bbfa3f8066dbcf696025af62e5cae7b8847 (patch)
tree95f70bc37ece7642d4414d17a933a3b758bc8bc3 /misc/goblin/Makefile
parent0ed345d0da86d7b818afe8a53d19178c858fe36f (diff)
downloadfreebsd-ports-gnome-15189bbfa3f8066dbcf696025af62e5cae7b8847.tar.gz
freebsd-ports-gnome-15189bbfa3f8066dbcf696025af62e5cae7b8847.tar.zst
freebsd-ports-gnome-15189bbfa3f8066dbcf696025af62e5cae7b8847.zip
upgrade to 2.6b5
Diffstat (limited to 'misc/goblin/Makefile')
-rw-r--r--misc/goblin/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/misc/goblin/Makefile b/misc/goblin/Makefile
index f81bbecba6d8..712c0b12f2bc 100644
--- a/misc/goblin/Makefile
+++ b/misc/goblin/Makefile
@@ -7,10 +7,10 @@
#
PORTNAME= goblin
-PORTVERSION= 2.5
+PORTVERSION= 2.6.b5
CATEGORIES= misc
MASTER_SITES= http://www.math.uni-augsburg.de/opt/goblin.docs/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
+DISTNAME= ${PORTNAME}.${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Graph Object Library for Network Programming Problems
@@ -23,14 +23,16 @@ USE_REINPLACE= yes
CFLAGS+= -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3 \
-I${X11BASE}/include
LIBS= -L${LOCALBASE}/lib -L${X11BASE}/lib
-
-PLIST_SUB+= PORTVER=${PORTVERSION}
+USE_GMAKE= yes
+PLIST_SUB+= PORTVER=${PORTVERSION:R}
post-patch:
@${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g ; \
s,g\+\+,${CXX},g ; \
s,%%CXXFLAGS%%,${CXXFLAGS},g ; s,%%LIBS%%,${LIBS},g ; \
s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/include/globals.h
+.for file in include/globals.h globals.cpp
+ @${REINPLACE_CMD} -e "s/malloc.h/stdlib.h/g" ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>