aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gone
diff options
context:
space:
mode:
authormph <mph@FreeBSD.org>1998-04-20 12:41:16 +0800
committermph <mph@FreeBSD.org>1998-04-20 12:41:16 +0800
commit478f50624add0d0bd179190d487ddab2e55a5a29 (patch)
treeff0b589f7356d78c17ea1aa00b033906e93a5829 /misc/gone
parent82e8c944ac5fe2c283fa98f46d1ee9b805660c53 (diff)
downloadfreebsd-ports-gnome-478f50624add0d0bd179190d487ddab2e55a5a29.tar.gz
freebsd-ports-gnome-478f50624add0d0bd179190d487ddab2e55a5a29.tar.zst
freebsd-ports-gnome-478f50624add0d0bd179190d487ddab2e55a5a29.zip
Make this port non-INTERACTIVE. If built using:
make WITH_SETUID=yes it will install setuid root, and verify system passwords. Otherwise, it will not.
Diffstat (limited to 'misc/gone')
-rw-r--r--misc/gone/Makefile25
1 files changed, 23 insertions, 2 deletions
diff --git a/misc/gone/Makefile b/misc/gone/Makefile
index 363898685bd2..fcf130c98504 100644
--- a/misc/gone/Makefile
+++ b/misc/gone/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 April 1998
# Whom: marcus
#
-# $Id: Makefile,v 1.1.1.1 1998/04/20 02:09:55 mph Exp $
+# $Id: Makefile,v 1.2 1998/04/20 03:17:26 mph Exp $
#
DISTNAME= gone-1.3
@@ -13,8 +13,29 @@ MASTER_SITES= http://jaguar.ir.miami.edu/~marcus/
MAINTAINER= marcus@miami.edu
GNU_CONFIGURE= yes
-IS_INTERACTIVE= yes
MAN1= gone.1
+.if !defined(WITH_SETUID)
+WITH_SETUID= no
+CONFIGURE_ENV= SETUID_Q=no
+SHOWHELP= yes
+.elif ${WITH_SETUID} == YES || ${WITH_SETUID} == yes || ${WITH_SETUID} == Yes
+CONFIGURE_ENV= SETUID_Q=yes
+.elif ${WITH_SETUID} == NO || ${WITH_SETUID} == no || ${WITH_SETUID} == No
+CONFIGURE_ENV= SETUID_Q=no
+.else
+ABORT= yes
+.endif
+
+pre-configure:
+.if defined(SHOWHELP)
+ @ ${ECHO_MSG} To authenticate system passwords, build with \"make WITH_SETUID=YES\".
+ @ ${ECHO_MSG} Running setuid could introduce security holes in your system.
+.endif
+.if defined(ABORT)
+ @ ${ECHO_MSG} I do not understand WITH_SETUID=${WITH_SETUID}. Set to YES or NO.
+ @ ${FALSE}
+.endif
+
.include <bsd.port.mk>