aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gopod/Makefile
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-10-26 02:35:20 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-10-26 02:35:20 +0800
commit66f15dbe2c0b81655b67725002dfed9711f065f5 (patch)
treeb1da419c5ead2cb4aac63d439d0c10c7e9833807 /misc/gopod/Makefile
parent140aded77674f9fff9b29e47194502fd9d514300 (diff)
downloadfreebsd-ports-gnome-66f15dbe2c0b81655b67725002dfed9711f065f5.tar.gz
freebsd-ports-gnome-66f15dbe2c0b81655b67725002dfed9711f065f5.tar.zst
freebsd-ports-gnome-66f15dbe2c0b81655b67725002dfed9711f065f5.zip
Update to 1.3 and split into master and slave port
Diffstat (limited to 'misc/gopod/Makefile')
-rw-r--r--misc/gopod/Makefile72
1 files changed, 30 insertions, 42 deletions
diff --git a/misc/gopod/Makefile b/misc/gopod/Makefile
index 6272afeb45f2..920159a31d37 100644
--- a/misc/gopod/Makefile
+++ b/misc/gopod/Makefile
@@ -1,71 +1,59 @@
-# New ports collection makefile for: gopod
-# Date created: 4 April 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
+# New ports collection makefile for: gopod
+# Date created: 4 April 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
#
# $FreeBSD$
#
PORTNAME= gopod
-PORTVERSION= 1.1
+PORTVERSION= 1.3
CATEGORIES= misc
-MASTER_SITES= http://critical.ch/distfiles/
+MASTER_SITES= http://gopod.free-go.net/gopod/ \
+ http://critical.ch/distfiles/
+PKGNAMEPREFIX?=
DISTNAME= goPod-${PORTVERSION}_linux_bsd
MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= Utility to cap/uncap an iPod
+COMMENT?= Utility to cap/uncap an iPod
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
USE_GMAKE= yes
-RESTRICTED= Unclear legal status in EU countries
+USE_REINPLACE= yes
-PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}/gtk-version
+RESTRICTED= Unclear legal status in EU countries
+.if ${PKGNAMEPREFIX} == ""
PLIST_FILES= bin/gopod
-
-.if defined(WITH_GUI)
-USE_X_PREFIX= yes
-USE_GNOME= gtk20
-WRKSRC= ${WRKDIR}/${DISTNAME}/gtk-version
-PLIST_FILES+= share/${PORTNAME}/capped.png \
- share/${PORTNAME}/go.png \
- share/${PORTNAME}/go_.png \
- share/${PORTNAME}/mask.xpm \
- share/${PORTNAME}/notdetected.png \
- share/${PORTNAME}/uncapped.png
-PLIST_DIRS+= share/${PORTNAME}
-.else
WRKSRC= ${WRKDIR}/${DISTNAME}/console-version
.endif
-pre-everything::
-.if !defined(WITH_GUI)
- @${ECHO_MSG}
- @${ECHO_MSG} "You may define WITH_GUI if you want the gui version"
- @${ECHO_MSG}
-.endif
+PORTDOCS= README_EN README_FR
post-patch:
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" \
- ${WRKSRC}/main.c > ${WRKSRC}/main.c.freebsd
- ${MV} ${WRKSRC}/main.c.freebsd ${WRKSRC}/main.c
+.if ${PKGNAMEPREFIX} == "gtk-"
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/main.c
+.endif
+ @${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' ${WRKSRC}/main.c
+ @${REINPLACE_CMD} -e 's|\($$(CC)\)|\1 ${CFLAGS}|; /strip/d' \
+ ${WRKSRC}/Makefile
do-install:
-.if defined(WITH_GUI)
- @${MKDIR} ${PREFIX}/share/${PORTNAME}
-.for file in capped.png go.png go_.png mask.xpm notdetected.png uncapped.png
- ${INSTALL_DATA} -m 0644 ${WRKSRC}/gfx/${file} ${PREFIX}/share/${PORTNAME}/${file}
-.endfor
+.if ${PKGNAMEPREFIX} == ""
${INSTALL_PROGRAM} -m 0110 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.else
- ${INSTALL_PROGRAM} -m 0110 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+.for f in ${DATAFILES}
+ ${INSTALL_DATA} ${WRKSRC}/gfx/${f} ${DATADIR}
+.endfor
+ ${INSTALL_PROGRAM} -m 0110 ${WRKSRC}/${PORTNAME} \
+ ${PREFIX}/bin/${UNIQUENAME}
.endif
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README_EN ${WRKSRC}/README_FR ${DOCSDIR}
-PLIST_FILES+= share/doc/${PORTNAME}/README_EN \
- share/doc/${PORTNAME}/README_FR
-PLIST_DIRS+= share/doc/${PORTNAME}
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
.endif
post-install: