aboutsummaryrefslogtreecommitdiffstats
path: root/misc/gtl
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-04-21 23:31:34 +0800
committerlawrance <lawrance@FreeBSD.org>2005-04-21 23:31:34 +0800
commite42676537b725d91b04614f4a349633bd9f1d798 (patch)
tree068bded9255d6c6424d44a6c3328b24bf5847c7e /misc/gtl
parent5a037fcecaf7ebc27dcd76ecbb6c39e23c52bec1 (diff)
downloadfreebsd-ports-gnome-e42676537b725d91b04614f4a349633bd9f1d798.tar.gz
freebsd-ports-gnome-e42676537b725d91b04614f4a349633bd9f1d798.tar.zst
freebsd-ports-gnome-e42676537b725d91b04614f4a349633bd9f1d798.zip
- Update to 1.2.1
PR: ports/80107 Submitted by: Ulrich Spoerlein <q@uni.de> Approved by: clement (mentor)
Diffstat (limited to 'misc/gtl')
-rw-r--r--misc/gtl/Makefile39
-rw-r--r--misc/gtl/distinfo4
-rw-r--r--misc/gtl/files/patch-aa18
-rw-r--r--misc/gtl/files/patch-ab11
-rw-r--r--misc/gtl/pkg-plist8
5 files changed, 37 insertions, 43 deletions
diff --git a/misc/gtl/Makefile b/misc/gtl/Makefile
index 6961bf83ed23..08e5ac2cf6eb 100644
--- a/misc/gtl/Makefile
+++ b/misc/gtl/Makefile
@@ -6,23 +6,42 @@
#
PORTNAME= gtl
-PORTVERSION= 0.3.3
+PORTVERSION= 1.2.1
CATEGORIES= misc
-# The original distribution files are not available
-# anymore from the master_sites (http://infosun.fmi.uni-passau.de/GTL/)
-MASTER_SITES= #
+# The original distribution files are no longer freely
+# available from the master_sites
+MASTER_SITES= # http://infosun.fmi.uni-passau.de/GTL/
DISTNAME= GTL-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= q@uni.de
COMMENT= C++ STL-based support for graphs and graph algorithms
+RESTRICTED= License forbids redistribution (source or binary)
+
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+USE_INC_LIBTOOL_VER=13
+USE_GNOME= lthack
+USE_GCC= 3.3 # Won't build with 3.4
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500035
-BROKEN= "Does not compile on 5.0"
+.if !exists("${DISTDIR}/${DISTFILES}") && !defined(PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE= \n\
+With the release of version 1.0.0 the download policy of GTL has been\n\
+changed. GTL can be downloaded free of charge for non-commercial use.\n\
+Please follow the steps below to get access to the download archive:\n\
+\n\
+Send an email to gtl-download@infosun.fmi.uni-passau.de containing the\n\
+following information: \n\
+- Your Name\n\
+- Your Affiliation\n\
+- And your email address. Please use your academic address, e.g. .edu, if\n\
+ you have. Otherwise your are classified as a "commercial" user.\n\
+As soon as possible you will receive an answer from the GTL Team containing\n\
+the access code to the download page.\n\
+\n\
+If you intend to use GTL commercially please send an email to\n\
+brandenb@fmi.uni-passau.de.\n
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/gtl/distinfo b/misc/gtl/distinfo
index 77a44a0e31f6..057dafb7b7fc 100644
--- a/misc/gtl/distinfo
+++ b/misc/gtl/distinfo
@@ -1,2 +1,2 @@
-MD5 (GTL-0.3.3.tar.gz) = 3fc4653715b8d3b32f9bee3f4ea01252
-SIZE (GTL-0.3.3.tar.gz) = 469283
+MD5 (GTL-1.2.1.tar.gz) = 7d4747bafc0520b97a674f20e37c901a
+SIZE (GTL-1.2.1.tar.gz) = 754505
diff --git a/misc/gtl/files/patch-aa b/misc/gtl/files/patch-aa
deleted file mode 100644
index ad5fcbeff581..000000000000
--- a/misc/gtl/files/patch-aa
+++ /dev/null
@@ -1,18 +0,0 @@
---- include/GTL/GTL.h.orig Fri Oct 1 13:22:15 1999
-+++ include/GTL/GTL.h Fri Oct 1 13:22:57 1999
-@@ -115,6 +115,7 @@
-
- #include <memory>
-
-+#ifndef __FreeBSD__
- /**
- * @internal
- */
-@@ -122,6 +123,7 @@
- class allocator : public alloc
- {
- };
-+#endif
-
- #endif
-
diff --git a/misc/gtl/files/patch-ab b/misc/gtl/files/patch-ab
deleted file mode 100644
index b39263d7a9f5..000000000000
--- a/misc/gtl/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/graph.cpp.orig Wed Jan 12 14:25:24 2000
-+++ src/graph.cpp Wed Jan 12 14:25:51 2000
-@@ -24,6 +24,8 @@
- #include <fstream>
- #include <string>
-
-+#include <map>
-+
- __GTL_BEGIN_NAMESPACE
-
- //--------------------------------------------------------------------------
diff --git a/misc/gtl/pkg-plist b/misc/gtl/pkg-plist
index 30b38c773f10..e9305b2f4af5 100644
--- a/misc/gtl/pkg-plist
+++ b/misc/gtl/pkg-plist
@@ -1,10 +1,14 @@
include/GTL/GTL.h
include/GTL/algorithm.h
+include/GTL/bellman_ford.h
include/GTL/bfs.h
include/GTL/biconnectivity.h
+include/GTL/bid_dijkstra.h
+include/GTL/bin_heap.h
include/GTL/components.h
include/GTL/debug.h
include/GTL/dfs.h
+include/GTL/dijkstra.h
include/GTL/edge.h
include/GTL/edge_data.h
include/GTL/edge_map.h
@@ -15,6 +19,8 @@ include/GTL/gml_scanner.h
include/GTL/graph.h
include/GTL/maxflow_ff.h
include/GTL/maxflow_pp.h
+include/GTL/maxflow_sap.h
+include/GTL/min_tree.h
include/GTL/ne_map.h
include/GTL/node.h
include/GTL/node_data.h
@@ -27,8 +33,6 @@ include/GTL/st_number.h
include/GTL/symlist.h
include/GTL/topsort.h
include/GTL/version.h
-lib/libGTL.a
-lib/libGTL.la
lib/libGTL.so
lib/libGTL.so.3
@dirrm include/GTL