aboutsummaryrefslogtreecommitdiffstats
path: root/misc/iselect/Makefile
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-03-25 12:30:31 +0800
committereadler <eadler@FreeBSD.org>2013-03-25 12:30:31 +0800
commitb188c769f2650f1a4c596b60d43f25ba20eed016 (patch)
treee9502ec9d580c1cb296d2b6e887c07a0737f2b7c /misc/iselect/Makefile
parent6441d65203b3635b4c310c9e76e9296880cb7826 (diff)
downloadfreebsd-ports-gnome-b188c769f2650f1a4c596b60d43f25ba20eed016.tar.gz
freebsd-ports-gnome-b188c769f2650f1a4c596b60d43f25ba20eed016.tar.zst
freebsd-ports-gnome-b188c769f2650f1a4c596b60d43f25ba20eed016.zip
Cleanup unmaintained ports in the misc category:
- Trim Header - Convert to OptionsNG - Prefer DISTNAME to DISTFILES - Reorder variables - Fix comments (don't include leading article) - @unexec rm must not cause failure - Tabs, not spaces - Single space for WWW - Pet portlint - etc. In a few cases the option DOCS was used to control installation into EXAMPLEDIR. I opted to keep the existing logic of the port in these cases. Reviewed by: koobs, ashish
Diffstat (limited to 'misc/iselect/Makefile')
-rw-r--r--misc/iselect/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/misc/iselect/Makefile b/misc/iselect/Makefile
index aa119234991a..64bc08a7984e 100644
--- a/misc/iselect/Makefile
+++ b/misc/iselect/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: iselect
-# Date created: 03-Jan-1998
-# Whom: Ralf S. Engelschall <rse@engelschall.com>
-#
+# Created by: Ralf S. Engelschall <rse@engelschall.com>
# $FreeBSD$
-#
PORTNAME= iselect
PORTVERSION= 1.4.0
@@ -14,11 +10,16 @@ MASTER_SITE_SUBDIR= tool/iselect
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive Selection Tool
+OPTIONS_DEFINE= SLANG
+SLANG_DESC= Link with slang
+
GNU_CONFIGURE= yes
MAN1= iselect.1
-.if defined(WITH_SLANG)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSLANG}
LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
CONFIGURE_ARGS+= --with-incdir=${LOCALBASE}/include \
--with-libdir=${LOCALBASE}/lib
@@ -30,7 +31,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/iselect ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/iselect.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/example && ${FIND} . | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}