aboutsummaryrefslogtreecommitdiffstats
path: root/misc/kdeaddons3/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2001-10-27 16:50:18 +0800
committerdemon <demon@FreeBSD.org>2001-10-27 16:50:18 +0800
commit82e0fea8b5d03b7ec004f592c68ed985169eaefd (patch)
tree4fbb9b23137e635839b2567e3e5a7d45e4c80053 /misc/kdeaddons3/Makefile
parentf36f894785f131508d2d104bf7f0b07b5c6278ba (diff)
downloadfreebsd-ports-gnome-82e0fea8b5d03b7ec004f592c68ed985169eaefd.tar.gz
freebsd-ports-gnome-82e0fea8b5d03b7ec004f592c68ed985169eaefd.tar.zst
freebsd-ports-gnome-82e0fea8b5d03b7ec004f592c68ed985169eaefd.zip
Upgrade to 2.2.1.
Submitted by: SASAKI Katuhiro <sahiro@crest.ocn.ne.jp> (with slight modifications)
Diffstat (limited to 'misc/kdeaddons3/Makefile')
-rw-r--r--misc/kdeaddons3/Makefile23
1 files changed, 21 insertions, 2 deletions
diff --git a/misc/kdeaddons3/Makefile b/misc/kdeaddons3/Makefile
index 0b0651ee9af8..26fe58557c84 100644
--- a/misc/kdeaddons3/Makefile
+++ b/misc/kdeaddons3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeaddons
-PORTVERSION= 2.2
+PORTVERSION= 2.2.1
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -21,4 +21,23 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
PLIST_SUB+= RM=${RM}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/include/SDL11/SDL.h)
+WITH_SDL= yes
+.endif
+
+.if defined(WITH_SDL) && ${WITH_SDL} == yes
+LIB_DEPENDS+= SDL-1.1.3:${PORTSDIR}/devel/sdl12
+CONFIGURE_ENV+= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
+PLIST_SUB+= SDL=""
+.else
+PLIST_SUB+= SDL="@comment "
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile with SDL support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SDL=yes\""
+ @${ECHO_MSG}
+.endif
+
+.include <bsd.port.post.mk>