aboutsummaryrefslogtreecommitdiffstats
path: root/misc/kdeaddons
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-12-04 11:47:18 +0800
committerwill <will@FreeBSD.org>2001-12-04 11:47:18 +0800
commitc468d09b79a9eac13941146231554832ce733e30 (patch)
tree7ce19e920fd8fee43a88c44cfcfaadc3081846dc /misc/kdeaddons
parent38faa34b2d2a41011556bf2ccde4785a7cb7c584 (diff)
downloadfreebsd-ports-gnome-c468d09b79a9eac13941146231554832ce733e30.tar.gz
freebsd-ports-gnome-c468d09b79a9eac13941146231554832ce733e30.tar.zst
freebsd-ports-gnome-c468d09b79a9eac13941146231554832ce733e30.zip
Upgrade KDE to 2.2.2:
* General: - Support for objprelink. - Hack for autoconf 2.13/automake 1.4. Note that we can't use the standard USE_AUTO* because they change things in work/*; KDE has its own way of doing that. - Light cleanup of extra dirs in the PLISTs provided by my mkplistpkg[1] script. - Speedups of both compile and runtime through the usage of --disable-debug and --enable-final. The latter did not work with the kdemultimedia package, unfortunately. - Patch updates. * audio/kdemultimedia2: - Patch to fix KSCD on FreeBSD[2]. It works very well now. * deskutils/kdepim: - Enable kpilot[3]. Pull in the latest pilot-link stuff. * devel/kdesdk, * devel/kdevelop: - No specific changes. * devel/qt-designer: - Make this port depend almost entirely on qt23 to make it more maintainable, so I don't have to keep hacking the patches to get them to apply. * editors/koffice, * games/kdegames, * graphics/kdegraphics: - No specific changes. * misc/kdeaddons: - SDL is required now. Cull SDL PLIST_SUB and such. - Fix breakage from hardcoding "sdl-config". * misc/kdeutils2: - Fix problem with klaptopdaemon[4] where it didn't properly display the battery time. This patch is untested, but applied. * net/kdenetwork2: - Fix DCC for KSIRC[5]. - Remove ktalkd from the build. It requires some weird thing in the configure script that I don't have time to look at. * sysutils/kdeadmin: - No specific changes. * textproc/kdoc: - Remove bogus requirement that kdoc requires Perl 5.6.0; it sure seems to operate fine with >= 5.005. But I'll let time tell. * www/quanta: - No specific changes (--disable-debug support only). * x11/kde2: - No specific changes. * x11/kdebase2: - Fix ksysguard compile by merging the files from the HEAD branch of KDE CVS that were missing at release time for FreeBSD[6]. :\ * x11/kdelibs2: - Recognize CUPS' spinoff[7]. - Add libxslt dependency since it was removed from kdelibs. - Fix libxml compile problems[8] (accomplished by upgrading). - Remove libkformula from port Makefile; this library has been spun off into koffice. - Fix mode problems with DCOP[9]. This allows you to save files properly. It also seems to be a FreeBSD specific problem. - Fix bashisms in kdeprint/imagetops script[10]. * x11-clocks/kdetoys2: - No specific changes. * x11-toolkits/qt23: - Do NOT upgrade to QT 2.3.2[11]. - Allow devel/qt-designer to depend on this port entirely for the patches by adding a perlre to accomplish this. * x11-wm/kdeartwork: - No specific changes. Thanks to the FreeBSD/KDE[1] team[12] who helped me test these out! [1] http://freebsd.kde.org/; http://www.databits.net/cgi-bin/cvsweb.cgi/scripts/portbuild/mkplistpkg [2] Submitted by: Matthew Holmes <matt@speakeasy.net> [3] PR: 31914 Submitted by: Alan Eldridge <alane@geeksrus.net> [4] PR: 28475 Submitted by: Arun Sharma <arun@sharmas.dhs.org> [5] Submitted by: Luc Morin <luc_m@videotron.ca> [6] Found at: http://webcvs.kde.org/kdebase/ksysguard/ksysguardd/FreeBSD/ [7] PR: 32321 Reported by: gad Submitted by: James A. Halstead <jah4007@cs.rit.edu> [8] PR: 32055 Reported by: William Richard <wrichard@trivalley.com>, others [9] PR: 31629 Submitted by: Alan Eldridge <alane@geeksrus.net> [10] PR: 32358 Submitted by: Alexander N. Kabaev <ak03@gte.com> [11] PR: 31809 Requested by: Nathan Ahlstrom <nrahlstr@winternet.com> (denied) [12] http://freebsd.kde.org/contact.shtml; http://lists.csociety.org/pipermail/kde-freebsd; http://lists.csociety.org/listinfo/kde-freebsd
Diffstat (limited to 'misc/kdeaddons')
-rw-r--r--misc/kdeaddons/Makefile46
-rw-r--r--misc/kdeaddons/distinfo2
-rw-r--r--misc/kdeaddons/pkg-plist60
3 files changed, 50 insertions, 58 deletions
diff --git a/misc/kdeaddons/Makefile b/misc/kdeaddons/Makefile
index 26fe58557c84..18fe7500dff1 100644
--- a/misc/kdeaddons/Makefile
+++ b/misc/kdeaddons/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kdeaddons
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES?= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -14,30 +14,40 @@ DIST_SUBDIR= KDE
MAINTAINER?= ports@FreeBSD.org
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14 \
+ objprelink:${PORTSDIR}/devel/objprelink
+LIB_DEPENDS+= noatun.0:${PORTSDIR}/audio/kdemultimedia2 \
+ SDL-1.1.3:${PORTSDIR}/devel/sdl12
+
+WITH_SDL= yes
USE_KDEBASE_VER=2
-LIB_DEPENDS+= noatun.0:${PORTSDIR}/audio/kdemultimedia2
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
PLIST_SUB+= RM=${RM}
+CONFIGURE_ENV+= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
+CONFIGURE_ARGS= --enable-objprelink
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/SDL11/SDL.h)
-WITH_SDL= yes
-.endif
-
-.if defined(WITH_SDL) && ${WITH_SDL} == yes
-LIB_DEPENDS+= SDL-1.1.3:${PORTSDIR}/devel/sdl12
-CONFIGURE_ENV+= SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
-PLIST_SUB+= SDL=""
-.else
-PLIST_SUB+= SDL="@comment "
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with SDL support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_SDL=yes\""
- @${ECHO_MSG}
-.endif
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=$$PATH:${WRKSRC}/auto-bin \
+ ${GMAKE} -f Makefile.cvs
+ find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ "s@sdl-config@${LOCALBASE}/bin/sdl11-config@g"
.include <bsd.port.post.mk>
diff --git a/misc/kdeaddons/distinfo b/misc/kdeaddons/distinfo
index 54bc41edca3c..40c40c31dea5 100644
--- a/misc/kdeaddons/distinfo
+++ b/misc/kdeaddons/distinfo
@@ -1 +1 @@
-MD5 (KDE/kdeaddons-2.2.1.tar.bz2) = 034f35ed3cd575b65f8ccc6110590d20
+MD5 (KDE/kdeaddons-2.2.2.tar.bz2) = 9392da0992f4aede5f6a86840e47fef6
diff --git a/misc/kdeaddons/pkg-plist b/misc/kdeaddons/pkg-plist
index 3eca8d5c45a4..de49b3f8b00c 100644
--- a/misc/kdeaddons/pkg-plist
+++ b/misc/kdeaddons/pkg-plist
@@ -1,11 +1,7 @@
-@unexec %%RM%% -f %D/lib/libkolourpicker.so
-@unexec %%RM%% -f %D/lib/libktimemon.so
-@unexec %%RM%% -f %D/share/doc/HTML/en/kate-plugins/common
-@unexec %%RM%% -f %D/share/doc/HTML/en/kicker-applets/common
bin/dcop_kate
-%%SDL%%bin/noatunsynaescope.bin
-%%SDL%%bin/noatuntippecanoe.bin
-%%SDL%%bin/noatuntyler.bin
+bin/noatunsynaescope.bin
+bin/noatuntippecanoe.bin
+bin/noatuntyler.bin
bin/testor
lib/kde2/libbabelfishplugin.la
lib/kde2/libbabelfishplugin.so
@@ -41,30 +37,30 @@ lib/libkolourpicker.so.1
lib/libktimemon.la
lib/libktimemon.so
lib/libktimemon.so.1
-%%SDL%%lib/libnoatunblurscope.la
-%%SDL%%lib/libnoatunblurscope.so
+lib/libnoatunblurscope.la
+lib/libnoatunblurscope.so
lib/libnoatunluckytag.la
lib/libnoatunluckytag.so
lib/libnoatunmadness.la
lib/libnoatunmadness.so
-%%SDL%%lib/libnoatunsynaescope.la
-%%SDL%%lib/libnoatunsynaescope.so
-%%SDL%%lib/libnoatuntippecanoe.la
-%%SDL%%lib/libnoatuntippecanoe.so
-%%SDL%%lib/libnoatuntyler.la
-%%SDL%%lib/libnoatuntyler.so
+lib/libnoatunsynaescope.la
+lib/libnoatunsynaescope.so
+lib/libnoatuntippecanoe.la
+lib/libnoatuntippecanoe.so
+lib/libnoatuntyler.la
+lib/libnoatuntyler.so
lib/libnoatunwakeup.la
lib/libnoatunwakeup.so
-share/apps/kate/plugins/katehtmltools/ui.rc
share/apps/kate/plugins/katehtmltools.desktop
-share/apps/kate/plugins/kateinsertcommand/ui.rc
+share/apps/kate/plugins/katehtmltools/ui.rc
share/apps/kate/plugins/kateinsertcommand.desktop
-share/apps/kate/plugins/kateopenheader/ui.rc
+share/apps/kate/plugins/kateinsertcommand/ui.rc
share/apps/kate/plugins/kateopenheader.desktop
-share/apps/kate/plugins/kateprojectmanager/ui.rc
+share/apps/kate/plugins/kateopenheader/ui.rc
share/apps/kate/plugins/kateprojectmanager.desktop
-share/apps/kate/plugins/katetextfilter/ui.rc
+share/apps/kate/plugins/kateprojectmanager/ui.rc
share/apps/kate/plugins/katetextfilter.desktop
+share/apps/kate/plugins/katetextfilter/ui.rc
share/apps/khtml/kpartplugins/khtmlsettingsplugin.rc
share/apps/khtml/kpartplugins/plugin_babelfish.rc
share/apps/khtml/kpartplugins/plugin_domtreeviewer.rc
@@ -84,13 +80,13 @@ share/apps/konqiconview/kpartplugins/dirfilterplugin.rc
share/apps/konqiconview/kpartplugins/kimgalleryplugin.rc
share/apps/konqlistview/kpartplugins/dirfilterplugin.rc
share/apps/konqlistview/kpartplugins/kimgalleryplugin.rc
-%%SDL%%share/apps/noatun/blurscope.plugin
+share/apps/noatun/blurscope.plugin
share/apps/noatun/luckytag.plugin
share/apps/noatun/madness.plugin
-%%SDL%%share/apps/noatun/synaescope.plugin
-%%SDL%%share/apps/noatun/tippecanoe.plugin
-%%SDL%%share/apps/noatun/tyler.plugin
-%%SDL%%share/apps/noatun/tylerstates
+share/apps/noatun/synaescope.plugin
+share/apps/noatun/tippecanoe.plugin
+share/apps/noatun/tyler.plugin
+share/apps/noatun/tylerstates
share/apps/noatun/wakeup.plugin
share/doc/HTML/en/kate-plugins/common
share/doc/HTML/en/kate-plugins/helloworld.docbook
@@ -124,28 +120,14 @@ share/icons/locolor/16x16/apps/ktimemon.png
share/icons/locolor/32x32/apps/ktimemon.png
share/mimelnk/application/x-webarchive.desktop
share/services/webarchivethumbnail.desktop
-@dirrm share/services
-@dirrm share/mimelnk/application
-@dirrm share/icons/locolor/32x32/apps
-@dirrm share/icons/locolor/16x16/apps
-@dirrm share/icons/hicolor/22x22/actions
-@dirrm share/icons/hicolor/16x16/actions
@dirrm share/doc/HTML/en/kicker-applets
@dirrm share/doc/HTML/en/kate-plugins
-@dirrm share/doc/HTML/en
-@dirrm share/apps/noatun
-@dirrm share/apps/konqlistview/kpartplugins
-@dirrm share/apps/konqiconview/kpartplugins
@dirrm share/apps/knewsticker/scripts
@dirrm share/apps/knewsticker
-@dirrm share/apps/kicker/applets
@dirrm share/apps/khtml/kpartplugins
-@dirrm share/apps/khtml
@dirrm share/apps/kate/plugins/katetextfilter
@dirrm share/apps/kate/plugins/kateprojectmanager
@dirrm share/apps/kate/plugins/kateopenheader
@dirrm share/apps/kate/plugins/kateinsertcommand
@dirrm share/apps/kate/plugins/katehtmltools
@dirrm share/apps/kate/plugins
-@dirrm share/apps/kate
-@dirrm lib/kde2