aboutsummaryrefslogtreecommitdiffstats
path: root/misc/koffice-i18n/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2001-12-18 21:32:10 +0800
committerdemon <demon@FreeBSD.org>2001-12-18 21:32:10 +0800
commit80200bf12e42162b1f688e55b41efc15c4240d39 (patch)
tree9f6dc6d356a9e685e3e71561e097785866cfa3f8 /misc/koffice-i18n/Makefile
parent37214af2688148a43a2ed0eabfed57e71e8a6016 (diff)
downloadfreebsd-ports-gnome-80200bf12e42162b1f688e55b41efc15c4240d39.tar.gz
freebsd-ports-gnome-80200bf12e42162b1f688e55b41efc15c4240d39.tar.zst
freebsd-ports-gnome-80200bf12e42162b1f688e55b41efc15c4240d39.zip
Localized messages for KOffice.
PR: 32932 Submitted by: SASAKI Katuhiro <sahiro@crest.ocn.ne.jp>
Diffstat (limited to 'misc/koffice-i18n/Makefile')
-rw-r--r--misc/koffice-i18n/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/misc/koffice-i18n/Makefile b/misc/koffice-i18n/Makefile
new file mode 100644
index 000000000000..fbf5456e83ad
--- /dev/null
+++ b/misc/koffice-i18n/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: koffice-i18n
+# Date created: 15 December 2001
+# Whom: SASAKI Katuhiro <sahiro@crest.ocn.ne.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= koffice-i18n
+PORTVERSION= 1.1
+CATEGORIES?= misc kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/koffice-${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER?= sahiro@crest.ocn.ne.jp
+
+BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
+ automake14:${PORTSDIR}/devel/automake14
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+RUN_DEPENDS= koshell:${PORTSDIR}/editors/koffice
+
+USE_KDELIBS_VER=2
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+PLIST= ${WRKDIR}/PLIST
+SCRIPTS_ENV+= PLIST=${PLIST}
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${MKDIR} ${WRKSRC}/auto-bin
+.for AC in autoconf autoheader
+ ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
+.endfor
+.for AM in automake aclocal
+ ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
+.endfor
+ cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
+ ${GMAKE} -f Makefile.cvs
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/Configure
+
+.include <bsd.port.post.mk>