aboutsummaryrefslogtreecommitdiffstats
path: root/misc/libemos
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2019-08-14 22:18:36 +0800
committeradridg <adridg@FreeBSD.org>2019-08-14 22:18:36 +0800
commit35c5634cd5df65c3917dc6c1241d4cf1ba4a7997 (patch)
treecb8cae671b5efc72a42d9447c877a471878c9fee /misc/libemos
parent4178370988b4b134462b425f570b212cf9d64881 (diff)
downloadfreebsd-ports-gnome-35c5634cd5df65c3917dc6c1241d4cf1ba4a7997.tar.gz
freebsd-ports-gnome-35c5634cd5df65c3917dc6c1241d4cf1ba4a7997.tar.zst
freebsd-ports-gnome-35c5634cd5df65c3917dc6c1241d4cf1ba4a7997.zip
Update devel/cmake to 3.15.2 (latest upstream release)
Release notes for the version updates are at: https://blog.kitware.com/cmake-3-15-0-available-for-download/ https://blog.kitware.com/cmake-3-15-1-available-for-download/ https://blog.kitware.com/cmake-3-15-2-available-for-download/ For FreeBSD, not much interesting has changed. Swift language support might be useful. A few ports were fixed as part of this exp-run (libemos not really related to the CMake update, but in general). Thanks to antoine for the exp-runs, tcberner for doing most of the prep-work. PR: 239273 Submitted by: tcberner
Diffstat (limited to 'misc/libemos')
-rw-r--r--misc/libemos/files/patch-libemos-dp_CMakeLists.txt13
-rw-r--r--misc/libemos/files/patch-libemos-sp_CMakeLists.txt13
-rw-r--r--misc/libemos/pkg-plist2
3 files changed, 28 insertions, 0 deletions
diff --git a/misc/libemos/files/patch-libemos-dp_CMakeLists.txt b/misc/libemos/files/patch-libemos-dp_CMakeLists.txt
new file mode 100644
index 000000000000..c67b62341241
--- /dev/null
+++ b/misc/libemos/files/patch-libemos-dp_CMakeLists.txt
@@ -0,0 +1,13 @@
+Fix build: the symlink to libemosR64.a was not created
+in ${STAGEDIR}, leading to fs_violations during poudriere test-builds.
+
+--- libemos-dp/CMakeLists.txt.orig 2019-08-10 23:48:55 UTC
++++ libemos-dp/CMakeLists.txt
+@@ -42,6 +42,6 @@ ecbuild_add_library(
+ # libemosR64.so ${CMAKE_INSTALL_PREFIX}/${INSTALL_LIB_DIR}/libemos.R64.D64.I32.so)" )
+ #else()
+ install(CODE "execute_process(COMMAND \"${CMAKE_COMMAND}\" -E create_symlink
+- libemosR64.a ${CMAKE_INSTALL_PREFIX}/${INSTALL_LIB_DIR}/libemos.R64.D64.I32.a)" )
++ libemosR64.a \$ENV{DESTDIR}/${CMAKE_INSTALL_PREFIX}/${INSTALL_LIB_DIR}/libemos.R64.D64.I32.a)" )
+ #endif()
+
diff --git a/misc/libemos/files/patch-libemos-sp_CMakeLists.txt b/misc/libemos/files/patch-libemos-sp_CMakeLists.txt
new file mode 100644
index 000000000000..16a6726b8aaf
--- /dev/null
+++ b/misc/libemos/files/patch-libemos-sp_CMakeLists.txt
@@ -0,0 +1,13 @@
+Fix build: the symlink to libemosR64.a was not created
+in ${STAGEDIR}, leading to fs_violations during poudriere test-builds.
+
+--- libemos-sp/CMakeLists.txt.orig 2019-08-10 23:49:07 UTC
++++ libemos-sp/CMakeLists.txt
+@@ -45,6 +45,6 @@ ecbuild_add_library(
+ # libemos.so ${CMAKE_INSTALL_PREFIX}/${INSTALL_LIB_DIR}/libemos.R32.D64.I32.so)" )
+ #else()
+ install(CODE "execute_process(COMMAND \"${CMAKE_COMMAND}\" -E create_symlink
+- libemos.a ${CMAKE_INSTALL_PREFIX}/${INSTALL_LIB_DIR}/libemos.R32.D64.I32.a)" )
++ libemos.a \$ENV{DESTDIR}/${CMAKE_INSTALL_PREFIX}/${INSTALL_LIB_DIR}/libemos.R32.D64.I32.a)" )
+ #endif()
+
diff --git a/misc/libemos/pkg-plist b/misc/libemos/pkg-plist
index 363051834ec7..aa397733dfd3 100644
--- a/misc/libemos/pkg-plist
+++ b/misc/libemos/pkg-plist
@@ -31,6 +31,8 @@ include/libemos/libemos_config.h
include/libemos/libemos_ecbuild_config.h
include/libemos/libemos_version.h
lib/libemos.a
+lib/libemos.R32.D64.I32.a
+lib/libemos.R64.D64.I32.a
lib/libemosR64.a
libdata/pkgconfig/libemos.pc
libdata/pkgconfig/libemosR64.pc