aboutsummaryrefslogtreecommitdiffstats
path: root/misc/lile/Makefile
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1997-06-28 08:54:47 +0800
committerjmz <jmz@FreeBSD.org>1997-06-28 08:54:47 +0800
commit5c73493d0843726937bef51c5b675651321b4935 (patch)
tree81210b237cdf9e6edeb9fc0ee269e3496ee1787b /misc/lile/Makefile
parent6b1aa5e6710480114e95fc4136141f9374d1f57e (diff)
downloadfreebsd-ports-gnome-5c73493d0843726937bef51c5b675651321b4935.tar.gz
freebsd-ports-gnome-5c73493d0843726937bef51c5b675651321b4935.tar.zst
freebsd-ports-gnome-5c73493d0843726937bef51c5b675651321b4935.zip
The ile program can be run as a simple shell around any program.
It gives any program an input line editing and a history mechanism. It can also be run around your favourite shell. When run around the shell ile records the input to interactive programs launched from the shell as well as the commands to the shell in its history buffer.
Diffstat (limited to 'misc/lile/Makefile')
-rw-r--r--misc/lile/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/misc/lile/Makefile b/misc/lile/Makefile
new file mode 100644
index 000000000000..792d433715b9
--- /dev/null
+++ b/misc/lile/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ile
+# Version required: 1.6
+# Date created: 25 Jun 1997
+# Whom: jmz
+#
+# $Id$
+#
+
+DISTNAME= lile
+PKGNAME= ile-1.6
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.inria.fr/system/user/
+EXTRACT_SUFX= .tar.Z
+MAINTAINER= jmz@FreeBSD.org
+
+MAN1= ile.1
+
+do-configure:
+ @(cd ${WRKSRC}; mv Makefile Makefile.old; \
+ sed -e s:/usr/local:${PREFIX}: <Makefile.old > Makefile; \
+ echo all: ile >> Makefile)
+
+.include <bsd.port.mk>