aboutsummaryrefslogtreecommitdiffstats
path: root/misc/lile
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1997-06-28 08:54:47 +0800
committerjmz <jmz@FreeBSD.org>1997-06-28 08:54:47 +0800
commit5c73493d0843726937bef51c5b675651321b4935 (patch)
tree81210b237cdf9e6edeb9fc0ee269e3496ee1787b /misc/lile
parent6b1aa5e6710480114e95fc4136141f9374d1f57e (diff)
downloadfreebsd-ports-gnome-5c73493d0843726937bef51c5b675651321b4935.tar.gz
freebsd-ports-gnome-5c73493d0843726937bef51c5b675651321b4935.tar.zst
freebsd-ports-gnome-5c73493d0843726937bef51c5b675651321b4935.zip
The ile program can be run as a simple shell around any program.
It gives any program an input line editing and a history mechanism. It can also be run around your favourite shell. When run around the shell ile records the input to interactive programs launched from the shell as well as the commands to the shell in its history buffer.
Diffstat (limited to 'misc/lile')
-rw-r--r--misc/lile/Makefile23
-rw-r--r--misc/lile/distinfo1
-rw-r--r--misc/lile/files/patch-aa19
-rw-r--r--misc/lile/pkg-comment1
-rw-r--r--misc/lile/pkg-descr6
-rw-r--r--misc/lile/pkg-plist2
6 files changed, 52 insertions, 0 deletions
diff --git a/misc/lile/Makefile b/misc/lile/Makefile
new file mode 100644
index 000000000000..792d433715b9
--- /dev/null
+++ b/misc/lile/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ile
+# Version required: 1.6
+# Date created: 25 Jun 1997
+# Whom: jmz
+#
+# $Id$
+#
+
+DISTNAME= lile
+PKGNAME= ile-1.6
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.inria.fr/system/user/
+EXTRACT_SUFX= .tar.Z
+MAINTAINER= jmz@FreeBSD.org
+
+MAN1= ile.1
+
+do-configure:
+ @(cd ${WRKSRC}; mv Makefile Makefile.old; \
+ sed -e s:/usr/local:${PREFIX}: <Makefile.old > Makefile; \
+ echo all: ile >> Makefile)
+
+.include <bsd.port.mk>
diff --git a/misc/lile/distinfo b/misc/lile/distinfo
new file mode 100644
index 000000000000..23b4962b2225
--- /dev/null
+++ b/misc/lile/distinfo
@@ -0,0 +1 @@
+MD5 (lile.tar.Z) = 983620a1bb49d776ec7ff9c46a5a3863
diff --git a/misc/lile/files/patch-aa b/misc/lile/files/patch-aa
new file mode 100644
index 000000000000..d9c70f461f6a
--- /dev/null
+++ b/misc/lile/files/patch-aa
@@ -0,0 +1,19 @@
+--- ile.c.orig Wed Jun 25 01:54:50 1997
++++ ile.c Wed Jun 25 01:55:24 1997
+@@ -65,7 +65,7 @@
+ #include <errno.h>
+ #include <sys/ioctl.h>
+ #include <sys/types.h>
+-#include <sys/dir.h>
++#include <sys/dirent.h>
+ #include <sys/file.h>
+ #include <sys/time.h>
+ /*
+@@ -75,7 +75,6 @@
+ /* Definitions of system stuff. */
+ extern int errno;
+
+-long lseek();
+ char *malloc();
+ char *realloc();
+ time_t time();
diff --git a/misc/lile/pkg-comment b/misc/lile/pkg-comment
new file mode 100644
index 000000000000..99b1a284b679
--- /dev/null
+++ b/misc/lile/pkg-comment
@@ -0,0 +1 @@
+An Input Line Editor that wraps itself around programs.
diff --git a/misc/lile/pkg-descr b/misc/lile/pkg-descr
new file mode 100644
index 000000000000..591851e570b0
--- /dev/null
+++ b/misc/lile/pkg-descr
@@ -0,0 +1,6 @@
+The ile program can be run as a simple shell around any program.
+It gives any program an input line editing and a history mechanism. It
+can also be run around your favourite shell. When run around the shell
+ile records the input to interactive programs launched from the
+shell as well as the commands to the shell in its history buffer.
+
diff --git a/misc/lile/pkg-plist b/misc/lile/pkg-plist
new file mode 100644
index 000000000000..b0ab53a4c27f
--- /dev/null
+++ b/misc/lile/pkg-plist
@@ -0,0 +1,2 @@
+bin/ile
+man/man1/ile.1.gz