aboutsummaryrefslogtreecommitdiffstats
path: root/misc/lxde-common
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-01-07 19:40:58 +0800
committernemysis <nemysis@FreeBSD.org>2014-01-07 19:40:58 +0800
commit105547b97ea8ab1fedd32934be1fcdd6b375d36d (patch)
tree11bc251195d4233091700af8073a4ebb19b7b426 /misc/lxde-common
parent1294b10ff5a251e2bd33ee24e4463b1e4918a7ee (diff)
downloadfreebsd-ports-gnome-105547b97ea8ab1fedd32934be1fcdd6b375d36d.tar.gz
freebsd-ports-gnome-105547b97ea8ab1fedd32934be1fcdd6b375d36d.tar.zst
freebsd-ports-gnome-105547b97ea8ab1fedd32934be1fcdd6b375d36d.zip
- USES gmake instead of USE_GMAKE
- Support STAGEDIR - Break lines around 80 characters
Diffstat (limited to 'misc/lxde-common')
-rw-r--r--misc/lxde-common/Makefile26
-rw-r--r--misc/lxde-common/pkg-plist3
2 files changed, 11 insertions, 18 deletions
diff --git a/misc/lxde-common/Makefile b/misc/lxde-common/Makefile
index cf0ae654766a..fabf77e70d0e 100644
--- a/misc/lxde-common/Makefile
+++ b/misc/lxde-common/Makefile
@@ -12,7 +12,7 @@ COMMENT= LXDE Common files
LICENSE= GPLv2
-USES= iconv
+USES= gmake iconv
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
@@ -21,31 +21,21 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
GMSGFMT="${LOCALBASE}/bin/msgfmt" \
--with-xsession-path=${PREFIX}/share/xsessions \
--with-xdg-path=${PREFIX}/share/applications
-USE_GMAKE= yes
DATADIR= ${PREFIX}/share/lxde
INSTALLS_ICONS= YES
-MAN1= startlxde.1 lxde-logout.1 openbox-lxde.1
-
PORTDOCS= AUTHORS README
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
- ${INSTALL_DATA} ${WRKSRC}/desktop.conf ${PREFIX}/etc/xdg/lxsession/LXDE/desktop.conf.sample
- ${INSTALL_DATA} ${WRKSRC}/pcmanfm/pcmanfm.conf ${PREFIX}/etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample
- @[ -f ${PREFIX}/etc/xdg/lxsession/LXDE/desktop.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/desktop.conf ${PREFIX}/etc/xdg/lxsession/LXDE/desktop.conf
- @[ -f ${PREFIX}/etc/xdg/pcmanfm/LXDE/pcmanfm.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/pcmanfm/pcmanfm.conf ${PREFIX}/etc/xdg/pcmanfm/LXDE/pcmanfm.conf
-
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/desktop.conf \
+ ${STAGEDIR}${PREFIX}/etc/xdg/lxsession/LXDE/desktop.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/pcmanfm/pcmanfm.conf \
+ ${STAGEDIR}${PREFIX}/etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/misc/lxde-common/pkg-plist b/misc/lxde-common/pkg-plist
index 207b568254fb..5586ac6b6536 100644
--- a/misc/lxde-common/pkg-plist
+++ b/misc/lxde-common/pkg-plist
@@ -8,6 +8,9 @@ etc/xdg/lxsession/LXDE/desktop.conf.sample
@unexec if cmp -s %D/etc/xdg/pcmanfm/LXDE/pcmanfm.conf %D/etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample; then rm -f %D/etc/xdg/pcmanfm/LXDE/pcmanfm.conf; fi
etc/xdg/pcmanfm/LXDE/pcmanfm.conf.sample
@exec if [ ! -f %D/etc/xdg/pcmanfm/LXDE/pcmanfm.conf ] ; then cp -p %D/%F %B/pcmanfm.conf; fi
+man/man1/lxde-logout.1.gz
+man/man1/openbox-lxde.1.gz
+man/man1/startlxde.1.gz
share/applications/lxde-logout.desktop
share/lxde/images/logout-banner.png
share/lxde/images/lxde-icon.png