aboutsummaryrefslogtreecommitdiffstats
path: root/misc/magicpoint/Makefile
diff options
context:
space:
mode:
authormita <mita@FreeBSD.org>2001-01-21 11:10:31 +0800
committermita <mita@FreeBSD.org>2001-01-21 11:10:31 +0800
commit96c2ab52ac7238cda81873e008bedd3fd10ee995 (patch)
treec5830b01a54d1b394d857a85ad6a81c007038f66 /misc/magicpoint/Makefile
parent14029bc4386dafef372e634c4d8ae84e3ea82f9a (diff)
downloadfreebsd-ports-gnome-96c2ab52ac7238cda81873e008bedd3fd10ee995.tar.gz
freebsd-ports-gnome-96c2ab52ac7238cda81873e008bedd3fd10ee995.tar.zst
freebsd-ports-gnome-96c2ab52ac7238cda81873e008bedd3fd10ee995.zip
Compilation failure problem under XFree86 version 3 is solved.
Reviewed by:ports-jp@jp.FreeBSD.org (ports-jp 10658)
Diffstat (limited to 'misc/magicpoint/Makefile')
-rw-r--r--misc/magicpoint/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index b9437cd0922c..dcc6b18361c7 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -35,20 +35,28 @@ EMACS_LISPS= mgp-mode.el mgp-el/COPYING mgp-el/README \
mgp-el/mgp.el mgp-el/mgp.sty mgp-el/sample.tex
SAMPLE_SCRIPTS= eqn2eps.sh tex2eps.sh mgp2html.pl mgp2latex.pl
+.include <bsd.port.pre.mk>
+
post-configure:
(cd ${WRKSRC}/contrib/xmindpath; ./configure --prefix=${PREFIX})
post-build:
- (cd ${WRKSRC}/contrib/xmindpath; make; \
+ (cd ${WRKSRC}/contrib/xmindpath; make)
+.if ${XFREE86_VERSION} == 4
+ (cd ${WRKSRC}/contrib/xmindpath; \
${RM} -f xmindpath.1.html xmindpath-1.html; \
${X11BASE}/bin/rman -f HTML < xmindpath.1 > xmindpath-1.html && \
${MV} -f xmindpath-1.html xmindpath.1.html)
+.endif
# NOTE: there are some discussions/twists in gzip'ing xmindpath.1.
post-install:
- (cd ${WRKSRC}/contrib/xmindpath; make install; \
- ${INSTALL_MAN} xmindpath.1.html ${PREFIX}/lib/X11/doc/html)
+ (cd ${WRKSRC}/contrib/xmindpath; make install)
${GZIP_CMD} ${PREFIX}/man/man1/xmindpath.1
+.if ${XFREE86_VERSION} == 4
+ (cd ${WRKSRC}/contrib/xmindpath;
+ ${INSTALL_MAN} xmindpath.1.html ${PREFIX}/lib/X11/doc/html)
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/mgp
for i in $(DOCS); do \
@@ -68,4 +76,4 @@ post-install:
done
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>