aboutsummaryrefslogtreecommitdiffstats
path: root/misc/mango/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-31 10:25:18 +0800
committerwill <will@FreeBSD.org>2001-03-31 10:25:18 +0800
commit6d0995f8f3bb43ef4e80108c3f33eeb766c4eb4f (patch)
tree482f1bd173a4ee61ada70d0ced5bd3a692d6cb76 /misc/mango/Makefile
parent0da488ef70ec4b36f620684f234f3d6a91998c9a (diff)
downloadfreebsd-ports-gnome-6d0995f8f3bb43ef4e80108c3f33eeb766c4eb4f.tar.gz
freebsd-ports-gnome-6d0995f8f3bb43ef4e80108c3f33eeb766c4eb4f.tar.zst
freebsd-ports-gnome-6d0995f8f3bb43ef4e80108c3f33eeb766c4eb4f.zip
Add mango 0.3, a recipe management software. Also the first port to
take advantage of -lqtgl provided by the newest QT2.3.0 port. PR: 26029 Submitted by: Roland Jesse <jesse@cs.uni-magdeburg.de>
Diffstat (limited to 'misc/mango/Makefile')
-rw-r--r--misc/mango/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/misc/mango/Makefile b/misc/mango/Makefile
new file mode 100644
index 000000000000..8508dee3c94c
--- /dev/null
+++ b/misc/mango/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mango
+# Date created: 23 March 2001
+# Whom: Roland Jesse <jesse@cs.uni-magdeburg.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mango
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= ftp://mango.sourceforge.net/pub/mango/
+
+MAINTAINER= jesse@cs.uni-magdeburg.de
+
+BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
+
+USE_BZIP2= yes
+USE_QT2= yes
+TMAKEENV= TMAKEPATH=${PREFIX}/share/tmake/freebsd-g++ QTDIR=${X11BASE}
+MAKE_ENV+= QTDIR=${X11BASE}
+
+do-build:
+ (cd ${WRKSRC}; ${SETENV} ${TMAKEENV} tmake -o Makefile mango.pro)
+ (${PERL} -pi.orig -e "s@-lqt2@-lqtgl@g" ${WRKSRC}/Makefile)
+ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/mango ${PREFIX}/bin
+
+.include <bsd.port.mk>