aboutsummaryrefslogtreecommitdiffstats
path: root/misc/misterproper/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-12-12 19:12:57 +0800
committersobomax <sobomax@FreeBSD.org>2000-12-12 19:12:57 +0800
commit77c2d6d03b7d8856bcf0404263aa673a86b0ccd3 (patch)
tree24dfa010b73a017cbef30ef7ee8e1ff6d7b12fae /misc/misterproper/Makefile
parent9c7016b4c570ace8dd5cb2b31e895cf8e6b6dd53 (diff)
downloadfreebsd-ports-gnome-77c2d6d03b7d8856bcf0404263aa673a86b0ccd3.tar.gz
freebsd-ports-gnome-77c2d6d03b7d8856bcf0404263aa673a86b0ccd3.tar.zst
freebsd-ports-gnome-77c2d6d03b7d8856bcf0404263aa673a86b0ccd3.zip
Add misterproper. Mister Proper is a GNOME tool designed to schedule your
cyclic tasks. It will keep track of what you should have done, what you really did, and is able to adjust each task's frequency until the optimal organization is found.
Diffstat (limited to 'misc/misterproper/Makefile')
-rw-r--r--misc/misterproper/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/misc/misterproper/Makefile b/misc/misterproper/Makefile
new file mode 100644
index 000000000000..d09a77bbe6b5
--- /dev/null
+++ b/misc/misterproper/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: misterproper
+# Date created: 12 December 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= misterproper
+PORTVERSION= 0.3
+CATEGORIES= misc gnome
+MASTER_SITES= ftp://misterproper.sourceforge.net/pub/misterproper/releases/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>