aboutsummaryrefslogtreecommitdiffstats
path: root/misc/mmv/Makefile
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>2002-06-15 02:14:16 +0800
committerse <se@FreeBSD.org>2002-06-15 02:14:16 +0800
commitd726a6444cc05fb7bfcc6190782a3b9676432219 (patch)
tree0bbbaeec94cd3102f2f799b04ce81e2a0dbe074e /misc/mmv/Makefile
parentbecd6fb7aa3f0a7dea994a55a861c171d8654388 (diff)
downloadfreebsd-ports-gnome-d726a6444cc05fb7bfcc6190782a3b9676432219.tar.gz
freebsd-ports-gnome-d726a6444cc05fb7bfcc6190782a3b9676432219.tar.zst
freebsd-ports-gnome-d726a6444cc05fb7bfcc6190782a3b9676432219.zip
Fix build on -current: initialization of FILE* outfile = stdout failed.
Testing the port revealed, that the SHAR archives could not be retrieved, but a TAR archive is available from wuarchive, so I converted the port to use it. This simplified the Makefile considerably as a side effect. Approved by: me@FreeBSD.org (port maintainer)
Diffstat (limited to 'misc/mmv/Makefile')
-rw-r--r--misc/mmv/Makefile29
1 files changed, 9 insertions, 20 deletions
diff --git a/misc/mmv/Makefile b/misc/mmv/Makefile
index 9278bdd4fb54..b11625e0bdc2 100644
--- a/misc/mmv/Makefile
+++ b/misc/mmv/Makefile
@@ -8,33 +8,22 @@
PORTNAME= mmv
PORTVERSION= 1.01b
CATEGORIES= misc
-MASTER_SITES= ftp://gatekeeper.dec.com/pub/usenet/comp.sources.unix/volume21/mmv/
-DISTFILES= part01.Z part02.Z
-
-PATCH_SITES= ftp://gatekeeper.dec.com/pub/usenet/comp.sources.unix/volume22/
-PATCHFILES= mmv.pch.Z
+MASTER_SITES= http://wuarchive.wustl.edu/languages/c/unix-c/file-mgmt/
+DISTNAME= mmv
+EXTRACT_SUFX= .tar.Z
MAINTAINER= me@FreeBSD.org
NO_CDROM= "No redistribution for charge"
NO_PACKAGE= "No modification"
-DIST_SUBDIR= ${PORTNAME}
-NO_WRKSUBDIR= yes
-PATCH_DIST_ARGS= -d ${WRKSRC} --forward --quiet -E ${PATCH_DIST_STRIP} mmv.c
+CFLAGS+= -DDIRENT
+MAKE_FLAGS= -e
MAN1= mmv.1
-do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}/tmp
- @(for file in ${DISTFILES}; do \
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/$$file ${WRKDIR}/tmp; \
- done ; \
- uncompress ${WRKDIR}/tmp/*; \
- cd ${WRKDIR}; \
- for file in tmp/part0* ; do \
- ${SH} ${SCRIPTDIR}/unshar $$file; \
- done ; \
- ${CAT} mmv.c.? >mmv.c ; ${RM} mmv.c.? )
+post-extract:
+ (cd ${WRKDIR}/${DISTNAME} ; \
+ ${CAT} mmv.c.? >mmv.c ; \
+ ${PATCH} mmv.c < mmv.patch1 ; )
do-install:
(cd ${PREFIX}/bin ; ${RM} -f mmv mad mcp mln ; \