aboutsummaryrefslogtreecommitdiffstats
path: root/misc/mmv/Makefile
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2010-05-04 02:52:54 +0800
committermandree <mandree@FreeBSD.org>2010-05-04 02:52:54 +0800
commit5743061cb23beb0de658ea2f58918cf370e5ec76 (patch)
tree56db0470b1553a05a4be83dd44281745ba6b2982 /misc/mmv/Makefile
parentc472da3eb059acf2fe5bceed0fd4e36b6fa68fd7 (diff)
downloadfreebsd-ports-gnome-5743061cb23beb0de658ea2f58918cf370e5ec76.tar.gz
freebsd-ports-gnome-5743061cb23beb0de658ea2f58918cf370e5ec76.tar.zst
freebsd-ports-gnome-5743061cb23beb0de658ea2f58918cf370e5ec76.zip
also install the default links mad, mcp, mln (append, copy, link) and manpages
bump PORTREVISION (changed pkg-plist) Approved by: Simon Olofsson <simon@olofsson.de> (maintainer) Approved by: garga (mentor)
Diffstat (limited to 'misc/mmv/Makefile')
-rw-r--r--misc/mmv/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/misc/mmv/Makefile b/misc/mmv/Makefile
index 56b69820255f..7771ebe12f48 100644
--- a/misc/mmv/Makefile
+++ b/misc/mmv/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mmv
PORTVERSION= 1.01b.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_1.01b.orig
@@ -20,8 +20,8 @@ MAINTAINER= simon@olofsson.de
COMMENT= Move/Copy/Append/Link multiple files
CFLAGS+= -DHAS_DIRENT
-MAN1= mmv.1
-PLIST_FILES= bin/mmv
+MAN1= mmv.1 mad.1 mcp.1 mln.1
+PLIST_FILES= bin/mmv bin/mad bin/mcp bin/mln
WRKSRC= ${WRKDIR}/${PORTNAME}-1.01b.orig
do-build:
@@ -30,6 +30,10 @@ do-build:
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- @${INSTALL_MAN} ${WRKSRC}/mmv.1 ${PREFIX}/man/man1/mmv.1
+ @${INSTALL_MAN} ${WRKSRC}/mmv.1 ${PREFIX}/man/man1/${PORTNAME}.1
+.for i in mcp mad mln
+ @${LN} ${PREFIX}/bin/${PORTNAME} ${PREFIX}/bin/${i}
+ @${LN} ${PREFIX}/man/man1/${PORTNAME}.1 ${PREFIX}/man/man1/${i}.1
+.endfor
.include <bsd.port.mk>