aboutsummaryrefslogtreecommitdiffstats
path: root/misc/ossp-uuid/Makefile
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2014-03-09 19:26:18 +0800
committervd <vd@FreeBSD.org>2014-03-09 19:26:18 +0800
commit13a467bd452ce370f23fa627a3f73ec122a37a15 (patch)
tree2631945fcbcccac0f3439ea1196f62315ab0436d /misc/ossp-uuid/Makefile
parenta0bec0153d81996649101043ae783afcc1aa275c (diff)
downloadfreebsd-ports-gnome-13a467bd452ce370f23fa627a3f73ec122a37a15.tar.gz
freebsd-ports-gnome-13a467bd452ce370f23fa627a3f73ec122a37a15.tar.zst
freebsd-ports-gnome-13a467bd452ce370f23fa627a3f73ec122a37a15.zip
misc/ossp-uuid: fix perl binding, patch based on [1]
PR: ports/187387 [1] Submitted by: culot@
Diffstat (limited to 'misc/ossp-uuid/Makefile')
-rw-r--r--misc/ossp-uuid/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index 137cb5a5792d..23cd2fd653b0 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -3,7 +3,7 @@
PORTNAME= uuid
PORTVERSION= 1.6.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc devel
MASTER_SITES= ${MASTER_SITE_OSSP}
MASTER_SITE_SUBDIR= lib/${PORTNAME}
@@ -12,7 +12,7 @@ PKGNAMEPREFIX= ossp-
MAINTAINER= vd@FreeBSD.org
COMMENT= ISO-C & Perl API and CLI for generating Universally Unique Identifiers
-CONFLICTS= e2fsprogs-libuuid-[0-9]*
+#CONFLICTS= e2fsprogs-libuuid-[0-9]*
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -20,12 +20,15 @@ CONFIGURE_ARGS= --disable-shared --enable-static --with-cxx \
--includedir=${PREFIX}/include/ossp
.if defined(WITH_PERL)
+MAKE_JOBS_UNSAFE= yes
USES+= perl5
CONFIGURE_ENV+= PERL=${PERL5}
-CONFIGURE_ARGS+= --with-perl
+CONFIGURE_ARGS+=--with-perl
+# Without WITH_PERL=yes in uuid's make args it could pick WITH_PERL=1 if
+# somebody has run "make WITH_PERL=1" in the port's directory, then its check
+# whether WITH_PERL is set to "yes" would fail.
+MAKE_ARGS+= WITH_PERL=yes
PLIST_SUB+= WITH_PERL=''
-MAN3= OSSP::uuid.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VER}
.else
PLIST_SUB+= WITH_PERL='@comment '
.endif
@@ -36,6 +39,10 @@ PLIST_SUB+= WITH_PERL='@comment '
CFLAGS+= -fPIC -DPIC
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's/\(libuuid\\*\.\)la/\1a/g' \
+ ${WRKSRC}/perl/Makefile.PL
+
regression-test: test
test: build