aboutsummaryrefslogtreecommitdiffstats
path: root/misc/p5-Geo-Coder-Multiple
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-12 14:18:55 +0800
committerwen <wen@FreeBSD.org>2010-03-12 14:18:55 +0800
commit144031191342cf65ac8d296a59f19a864bdad563 (patch)
tree63b2bf935bfd59f074ec88657590ab16fd676cff /misc/p5-Geo-Coder-Multiple
parent661f7b7f79af0de234db5fb64f55aab9beb90a3b (diff)
downloadfreebsd-ports-gnome-144031191342cf65ac8d296a59f19a864bdad563.tar.gz
freebsd-ports-gnome-144031191342cf65ac8d296a59f19a864bdad563.tar.zst
freebsd-ports-gnome-144031191342cf65ac8d296a59f19a864bdad563.zip
Geo::Coder::Multiple is a wrapper for multiple Geo::Coder::* modules.
Most free geocoding datasource specify a limit to the number of queries which can be sent from an IP or made using an API key in a 24 hour period. This module balances the incoming requests across the available sources to ensure individual limits are exceeded only when the total limit is exceeded. The algorithm for load balancing takes into account the limit imposed by the source per 24 hour period. WWW: http://search.cpan.org/dist/Geo-Coder-Multiple/
Diffstat (limited to 'misc/p5-Geo-Coder-Multiple')
-rw-r--r--misc/p5-Geo-Coder-Multiple/Makefile24
-rw-r--r--misc/p5-Geo-Coder-Multiple/distinfo3
-rw-r--r--misc/p5-Geo-Coder-Multiple/pkg-descr11
-rw-r--r--misc/p5-Geo-Coder-Multiple/pkg-plist14
4 files changed, 52 insertions, 0 deletions
diff --git a/misc/p5-Geo-Coder-Multiple/Makefile b/misc/p5-Geo-Coder-Multiple/Makefile
new file mode 100644
index 000000000000..ec295781bb9e
--- /dev/null
+++ b/misc/p5-Geo-Coder-Multiple/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Geo-Coder-Multiple
+# Date created: 12th March, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-Multiple
+PORTVERSION= 0.59
+CATEGORIES= misc perl5 geography
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Perl module to tie together multiple Geo::Coder modules
+
+RUN_DEPENDS= p5-List-Util-WeightedRoundRobin>=0:${PORTSDIR}/misc/p5-List-Util-WeightedRoundRobin
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::Multiple.3
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Geo-Coder-Multiple/distinfo b/misc/p5-Geo-Coder-Multiple/distinfo
new file mode 100644
index 000000000000..a2f045c0cb58
--- /dev/null
+++ b/misc/p5-Geo-Coder-Multiple/distinfo
@@ -0,0 +1,3 @@
+MD5 (Geo-Coder-Multiple-0.59.tar.gz) = 94918937355bd83bc3e9afe3d19e5418
+SHA256 (Geo-Coder-Multiple-0.59.tar.gz) = 60a148609899ed9ab86ba426ea5f19d7d279c1d58743bd7ff5cda73003c7acf7
+SIZE (Geo-Coder-Multiple-0.59.tar.gz) = 5077
diff --git a/misc/p5-Geo-Coder-Multiple/pkg-descr b/misc/p5-Geo-Coder-Multiple/pkg-descr
new file mode 100644
index 000000000000..d9e1a811e1ed
--- /dev/null
+++ b/misc/p5-Geo-Coder-Multiple/pkg-descr
@@ -0,0 +1,11 @@
+Geo::Coder::Multiple is a wrapper for multiple Geo::Coder::* modules.
+
+Most free geocoding datasource specify a limit to the number of queries which
+can be sent from an IP or made using an API key in a 24 hour period. This
+module balances the incoming requests across the available sources to ensure
+individual limits are exceeded only when the total limit is exceeded.
+
+The algorithm for load balancing takes into account the limit imposed by the
+source per 24 hour period.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-Multiple/
diff --git a/misc/p5-Geo-Coder-Multiple/pkg-plist b/misc/p5-Geo-Coder-Multiple/pkg-plist
new file mode 100644
index 000000000000..93d7ca14b7df
--- /dev/null
+++ b/misc/p5-Geo-Coder-Multiple/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Geo/Coder/Multiple.pm
+%%SITE_PERL%%/Geo/Coder/Multiple/Bing.pm
+%%SITE_PERL%%/Geo/Coder/Multiple/Generic.pm
+%%SITE_PERL%%/Geo/Coder/Multiple/Google.pm
+%%SITE_PERL%%/Geo/Coder/Multiple/Yahoo.pm
+%%SITE_PERL%%/Geo/Coder/Multiple/Response.pm
+%%SITE_PERL%%/Geo/Coder/Multiple/Multimap.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Multiple/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Multiple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder/Multiple
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo