aboutsummaryrefslogtreecommitdiffstats
path: root/misc/p5-OSSP-uuid
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2014-03-17 17:01:44 +0800
committerculot <culot@FreeBSD.org>2014-03-17 17:01:44 +0800
commita7c18bfcd9737843359b9e3af9bbf9089cce4dff (patch)
tree601bcfdc3e7c787d736f9f0d8a7071b8b90fa377 /misc/p5-OSSP-uuid
parent8e0fa788785246fba6624eba65f213a94217abc3 (diff)
downloadfreebsd-ports-gnome-a7c18bfcd9737843359b9e3af9bbf9089cce4dff.tar.gz
freebsd-ports-gnome-a7c18bfcd9737843359b9e3af9bbf9089cce4dff.tar.zst
freebsd-ports-gnome-a7c18bfcd9737843359b9e3af9bbf9089cce4dff.zip
- Add misc/p5-OSSP-uuid as a replacement for misc/ossp-uuid-perl.
p5-OSSP-uuid only installs the Perl API, hence avoiding to have two conflicting ports as was the case with ossp-uuid and ossp-uuid-perl. Suggested by: mat@ Approved by: vd@ (ossp-uuid maintainer, via email)
Diffstat (limited to 'misc/p5-OSSP-uuid')
-rw-r--r--misc/p5-OSSP-uuid/Makefile22
-rw-r--r--misc/p5-OSSP-uuid/files/patch-perl__Makefile.PL26
-rw-r--r--misc/p5-OSSP-uuid/pkg-descr7
-rw-r--r--misc/p5-OSSP-uuid/pkg-plist9
4 files changed, 64 insertions, 0 deletions
diff --git a/misc/p5-OSSP-uuid/Makefile b/misc/p5-OSSP-uuid/Makefile
new file mode 100644
index 000000000000..b2b368fbc14d
--- /dev/null
+++ b/misc/p5-OSSP-uuid/Makefile
@@ -0,0 +1,22 @@
+# Created by: Frederic Culot <culot@FreeBSD.org>
+# $FreeBSD$
+
+COMMENT= Perl bindings for ossp-uuid
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libuuid.a:${PORTSDIR}/misc/ossp-uuid
+
+SLAVEPORT= perl
+USES= perl5
+USE_PERL5= configure
+
+MASTERDIR= ${.CURDIR}/../../misc/ossp-uuid
+WRKSRC= ${WRKDIR}/${DISTNAME}/perl
+PLIST= ${.CURDIR}/pkg-plist
+DESCR= ${.CURDIR}/pkg-descr
+PATCHDIR= ${.CURDIR}/files
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/Makefile.PL
+
+.include "${MASTERDIR}/Makefile"
diff --git a/misc/p5-OSSP-uuid/files/patch-perl__Makefile.PL b/misc/p5-OSSP-uuid/files/patch-perl__Makefile.PL
new file mode 100644
index 000000000000..7912be67b1b3
--- /dev/null
+++ b/misc/p5-OSSP-uuid/files/patch-perl__Makefile.PL
@@ -0,0 +1,26 @@
+--- Makefile.PL.orig 2014-03-11 16:59:58.443768044 +0100
++++ Makefile.PL 2014-03-11 17:00:36.554952157 +0100
+@@ -32,11 +32,6 @@
+ use Config;
+ use ExtUtils::MakeMaker;
+
+-# determine source directory
+-my ($srcdir) = map { my $d = $_; $d =~ s/\/libuuid\.la$//; $d }
+- grep { -f $_ } ("../libuuid.la", glob("../*/libuuid.la"))
+- or die "no source directory found (where libuuid.la is located)";
+-
+ # determine extra build options
+ my $compat = 0;
+ @ARGV = grep { $_ =~ m/^COMPAT=(\d+)$/i ? ($compat = $1, 0) : 1 } @ARGV;
+@@ -47,9 +42,9 @@
+ VERSION_FROM => 'uuid.pm',
+ ABSTRACT_FROM => 'uuid.pod',
+ PREREQ_PM => {},
+- LIBS => [ "-L$srcdir/.libs -L$srcdir -luuid" ],
++ LIBS => [ "-L%%LOCALBASE%%/lib -luuid" ],
+ DEFINE => '',
+- INC => "-I. -I$srcdir",
++ INC => "-I. -I%%LOCALBASE%%/include/ossp",
+ PM => { 'uuid.pm' => '$(INST_LIBDIR)/uuid.pm',
+ 'uuid.pod' => '$(INST_LIBDIR)/uuid.pod',
+ ($compat ? ('uuid_compat.pm' => '$(INST_LIBDIR)/../Data/UUID.pm') : ()),
diff --git a/misc/p5-OSSP-uuid/pkg-descr b/misc/p5-OSSP-uuid/pkg-descr
new file mode 100644
index 000000000000..a3fa908b3395
--- /dev/null
+++ b/misc/p5-OSSP-uuid/pkg-descr
@@ -0,0 +1,7 @@
+OSSP::uuid is the Perl API to the ossp-uuid library which is used to
+generate DCE 1.1 and ISO/IEC 11578:1996 compliant Universally Unique
+Identifiers (UUID). It supports DCE 1.1 variant UUIDs of version 1
+(time and node based), version 3 (name based, MD5), version 4
+(random number based) and version 5 (name based, SHA-1).
+
+WWW: http://www.ossp.org/pkg/lib/uuid/
diff --git a/misc/p5-OSSP-uuid/pkg-plist b/misc/p5-OSSP-uuid/pkg-plist
new file mode 100644
index 000000000000..be543f49c752
--- /dev/null
+++ b/misc/p5-OSSP-uuid/pkg-plist
@@ -0,0 +1,9 @@
+%%PERL5_MAN3%%/OSSP::uuid.3.gz
+%%SITE_PERL%%/%%PERL_ARCH%%/OSSP/uuid.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/OSSP/uuid.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OSSP/uuid/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OSSP/uuid/uuid.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OSSP/uuid/uuid.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/OSSP/uuid
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OSSP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OSSP