aboutsummaryrefslogtreecommitdiffstats
path: root/misc/parley/Makefile
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
committeravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
commit18f8d6818a2205ed543432ae7b736e36bb0b1ab5 (patch)
treea38d8a80d7330fafe33e6504e265797c7db5c8ee /misc/parley/Makefile
parent7e1a35526ca99e8f9cc466c562f4184911eb911c (diff)
downloadfreebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.gz
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.zst
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.zip
The KDE/FreeBSD team is pleased to announce KDE Software Compilation
4.7.2. The official release notes can be found at: http://kde.org/announcements/announce-4.7.2.php This release ships with many improvements. Read more about them here: http://FreeBSD.kde.org/news.php#itemKDESC472availableinports We'd like to say thanks to all testers and contributors, especially to lwhsu@ for his effort on hosting our test packages. PR: 156293 [1] 159219 [2] 160164 [3] Submitted by: Oleg Sidorkin <osidorkin@gmail.com> [1] Alvaro Castillo <gobledb@gmail.com> [2] dkeav04@gmail.com [3] Tested by: exp-run via pav
Diffstat (limited to 'misc/parley/Makefile')
-rw-r--r--misc/parley/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/misc/parley/Makefile b/misc/parley/Makefile
new file mode 100644
index 000000000000..f050e45cb5ed
--- /dev/null
+++ b/misc/parley/Makefile
@@ -0,0 +1,32 @@
+# New ports collection Makefile for: parley
+# Date created: 6 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= parley
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= misc kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Vocabulary trainer for KDE 4
+
+LIB_DEPENDS= attica.0:${PORTSDIR}/x11-toolkits/attica \
+ keduvocdocument.5:${PORTSDIR}/misc/libkdeedu
+
+CONFLICTS= kdeedu-4.[0-6].*
+
+USE_GNOME= libxml2 libxslt
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib moc_build qmake_build rcc_build uic_build
+USE_XORG= x11 xrender
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>