aboutsummaryrefslogtreecommitdiffstats
path: root/misc/pdmenu/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-08-03 06:34:23 +0800
committermiwi <miwi@FreeBSD.org>2008-08-03 06:34:23 +0800
commitd991b857f151264f0ec4f5c3f9abcec897a68d9f (patch)
treec5f68f79c9a4d024f95f6047c20e46c177226977 /misc/pdmenu/Makefile
parentb6d02b38091a1ae4a1e591542902775d2924f8b8 (diff)
downloadfreebsd-ports-gnome-d991b857f151264f0ec4f5c3f9abcec897a68d9f.tar.gz
freebsd-ports-gnome-d991b857f151264f0ec4f5c3f9abcec897a68d9f.tar.zst
freebsd-ports-gnome-d991b857f151264f0ec4f5c3f9abcec897a68d9f.zip
- Update to 1.2.95
- Update WWW PR: 126175 Submitted by: Ports Fury
Diffstat (limited to 'misc/pdmenu/Makefile')
-rw-r--r--misc/pdmenu/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/misc/pdmenu/Makefile b/misc/pdmenu/Makefile
index 63755c54ef50..253a47c8d742 100644
--- a/misc/pdmenu/Makefile
+++ b/misc/pdmenu/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= pdmenu
-PORTVERSION= 1.2.93
-PORTREVISION= 1
+PORTVERSION= 1.2.95
CATEGORIES= misc
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -14,7 +13,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple console menu program
-LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
+OPTIONS= SLANG2 "Build using libslang-2.x" off
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -36,6 +35,14 @@ PLIST_FILES= bin/pdmenu \
%%DATADIR%%/showdir.pl
PLIST_DIRS= %%DATADIR%%
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SLANG2)
+LIB_DEPENDS+= slang.2:${PORTSDIR}/devel/libslang2
+.else
+LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pdmenu ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/examples/pdmenurc ${PREFIX}/etc
@@ -52,4 +59,4 @@ do-install:
post-install:
@${STRIP_CMD} ${PREFIX}/bin/pdmenu
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>