aboutsummaryrefslogtreecommitdiffstats
path: root/misc/pinfo/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2000-11-17 22:51:05 +0800
committerkevlo <kevlo@FreeBSD.org>2000-11-17 22:51:05 +0800
commitc237d7bb052e02145c30192064ad0f759b8f56bf (patch)
treebf6948fc654a0b5b52f4e210c1e4352893b5f830 /misc/pinfo/Makefile
parentebc60dc1134892b8ee3749d53d80ff52d2c03f64 (diff)
downloadfreebsd-ports-gnome-c237d7bb052e02145c30192064ad0f759b8f56bf.tar.gz
freebsd-ports-gnome-c237d7bb052e02145c30192064ad0f759b8f56bf.tar.zst
freebsd-ports-gnome-c237d7bb052e02145c30192064ad0f759b8f56bf.zip
- Support libintl library properly
- Use LOCALBASE to refer external dependancy files PR: 22891 Submitted by: Ports Fury
Diffstat (limited to 'misc/pinfo/Makefile')
-rw-r--r--misc/pinfo/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/misc/pinfo/Makefile b/misc/pinfo/Makefile
index 6a7a7ec05203..0d19ad1568d0 100644
--- a/misc/pinfo/Makefile
+++ b/misc/pinfo/Makefile
@@ -15,17 +15,21 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-included-gettext --with-readline
-CONFIGURE_ENV= LIBS="-lgnuregex -L${PREFIX}/lib -lintl" \
- CFLAGS="${CFLAGS} -I${PREFIX}/include"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnuregex"
+CONFIGURE_ARGS= --with-readline
MAN1= pinfo.1
+pre-patch:
+ @${PERL} -pi -e \
+ 's|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400010
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-CONFIGURE_ARGS+= --with-ncurses=${PREFIX}
+CONFIGURE_ARGS+= --with-ncurses=${LOCALBASE}
.endif
.include <bsd.port.post.mk>