aboutsummaryrefslogtreecommitdiffstats
path: root/misc/pipe
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-04-07 08:03:30 +0800
committerhq <hq@FreeBSD.org>2005-04-07 08:03:30 +0800
commit27f4348554467617b581e75c3fa270f9d2123acd (patch)
tree66a4cc189a814379fee43a8e09977a7bf63a9eb7 /misc/pipe
parentf40bdbd11ba6f06ebb7dab2959028010f4d277e2 (diff)
downloadfreebsd-ports-gnome-27f4348554467617b581e75c3fa270f9d2123acd.tar.gz
freebsd-ports-gnome-27f4348554467617b581e75c3fa270f9d2123acd.tar.zst
freebsd-ports-gnome-27f4348554467617b581e75c3fa270f9d2123acd.zip
Install data files using FIND | INSTALL_DATA
Submitted by: Sam Lawrance <boris@brooknet.com.au>
Diffstat (limited to 'misc/pipe')
-rw-r--r--misc/pipe/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/misc/pipe/Makefile b/misc/pipe/Makefile
index a81cb82fdc7c..74cb0a2e5525 100644
--- a/misc/pipe/Makefile
+++ b/misc/pipe/Makefile
@@ -33,7 +33,10 @@ PORTDOCS= javadoc license manual
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/pipe.sh ${PREFIX}/bin/pipe
@${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/bin/ ${DATADIR}
+ cd ${WRKSRC}/bin && \
+ ${FIND} . -type d -exec ${MKDIR} ${DATADIR}/{} \;
+ cd ${WRKSRC}/bin && \
+ ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
${LN} -s ${DATADIR}/petri-nets ${DATADIR}/Example\ nets
@${FIND} ${DATADIR} ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}