aboutsummaryrefslogtreecommitdiffstats
path: root/misc/porteasy
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2002-12-11 03:42:14 +0800
committerdes <des@FreeBSD.org>2002-12-11 03:42:14 +0800
commit0d63dbac5f8442f20a3e48ebcae203ad3f8a62d0 (patch)
tree02e58912c2108346567592664faa53a0b8c5f5df /misc/porteasy
parente3ae7b4fad964e782f0a3e8c7707a2aaff2cec94 (diff)
downloadfreebsd-ports-gnome-0d63dbac5f8442f20a3e48ebcae203ad3f8a62d0.tar.gz
freebsd-ports-gnome-0d63dbac5f8442f20a3e48ebcae203ad3f8a62d0.tar.zst
freebsd-ports-gnome-0d63dbac5f8442f20a3e48ebcae203ad3f8a62d0.zip
Fix a bug in the dependency processing code that would cause porteasy to
fail to identify the dependencies for some ports (such as print/cups) Approved by: portmgr (kris)
Diffstat (limited to 'misc/porteasy')
-rw-r--r--misc/porteasy/Makefile2
-rw-r--r--misc/porteasy/src/porteasy.pl1
2 files changed, 2 insertions, 1 deletions
diff --git a/misc/porteasy/Makefile b/misc/porteasy/Makefile
index e23b4b686441..3ac20f7bc46d 100644
--- a/misc/porteasy/Makefile
+++ b/misc/porteasy/Makefile
@@ -9,7 +9,7 @@
PORTNAME= porteasy
PORTVERSION= 2.7.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/misc/porteasy/src/porteasy.pl b/misc/porteasy/src/porteasy.pl
index 9c84855a76b5..aa009e0860c1 100644
--- a/misc/porteasy/src/porteasy.pl
+++ b/misc/porteasy/src/porteasy.pl
@@ -554,6 +554,7 @@ sub add_dependencies($$@) {
foreach $item (@dependlist) {
$item =~ s|\`([^\`]+)\`|capture(\&cmd, "sh", "-c", $1)|eg;
+ 1 while ($item =~ s|/[^\./]*/\.\./|/|);
if ($item !~ m|^(?:([^:]+):)?$portsdir/([^/:]+/[^/:]+)/?(:[^:]+)?$|) {
bsd::warnx("invalid dependency: %s", $item);
next;