aboutsummaryrefslogtreecommitdiffstats
path: root/misc/porteasy
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2004-10-25 20:01:23 +0800
committerdes <des@FreeBSD.org>2004-10-25 20:01:23 +0800
commit76c7453d7f0da64291a60a781089eb1d553a6d8c (patch)
treee0c452f418f30b219589d4808826f66289886c83 /misc/porteasy
parent13d553cf6afe6042746a9815bd355dfd505c9b18 (diff)
downloadfreebsd-ports-gnome-76c7453d7f0da64291a60a781089eb1d553a6d8c.tar.gz
freebsd-ports-gnome-76c7453d7f0da64291a60a781089eb1d553a6d8c.tar.zst
freebsd-ports-gnome-76c7453d7f0da64291a60a781089eb1d553a6d8c.zip
Recognize absolute master directories.
Diffstat (limited to 'misc/porteasy')
-rw-r--r--misc/porteasy/Makefile2
-rw-r--r--misc/porteasy/src/porteasy.pl3
2 files changed, 3 insertions, 2 deletions
diff --git a/misc/porteasy/Makefile b/misc/porteasy/Makefile
index 9c4c07e01e75..14a82560b08d 100644
--- a/misc/porteasy/Makefile
+++ b/misc/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.7.19
+PORTVERSION= 2.7.20
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/misc/porteasy/src/porteasy.pl b/misc/porteasy/src/porteasy.pl
index 9c2a4875d304..651675e71ed7 100644
--- a/misc/porteasy/src/porteasy.pl
+++ b/misc/porteasy/src/porteasy.pl
@@ -33,7 +33,7 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.7.19";
+my $VERSION = "2.7.20";
my $COPYRIGHT = "Copyright (c) 2000-2004 Dag-Erling Smørgrav. " .
"All rights reserved.";
@@ -579,6 +579,7 @@ sub find_master($) {
}
if (defined($master) && $master !~ m/WRKDIRPREFIX/) {
$master =~ s/^\$\{.CURDIR\}//;
+ $master =~ s/^\$\{PORTSDIR}/..\/../;
$master = "/$port/$master";
$master =~ s|/+|/|g;
1 while ($master =~ s|/[^\./]*/\.\./|/|);