aboutsummaryrefslogtreecommitdiffstats
path: root/misc/porteasy
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2002-01-24 18:11:43 +0800
committerdes <des@FreeBSD.org>2002-01-24 18:11:43 +0800
commit8cb0c94ebf790254beef249d6a3258238686fa70 (patch)
tree4ae08bd53c39f8dbf3cfd4d7a761f916301e963a /misc/porteasy
parent05c4c5fc1bfa1a7ab4fb9878e7efc55de7320273 (diff)
downloadfreebsd-ports-gnome-8cb0c94ebf790254beef249d6a3258238686fa70.tar.gz
freebsd-ports-gnome-8cb0c94ebf790254beef249d6a3258238686fa70.tar.zst
freebsd-ports-gnome-8cb0c94ebf790254beef249d6a3258238686fa70.zip
Fix the master port detection logic to correctly handle KDE ports.
Bump version to 2.6.3.
Diffstat (limited to 'misc/porteasy')
-rw-r--r--misc/porteasy/Makefile2
-rw-r--r--misc/porteasy/src/porteasy.pl4
2 files changed, 3 insertions, 3 deletions
diff --git a/misc/porteasy/Makefile b/misc/porteasy/Makefile
index 47aef10cf1ae..5c738edd1aa7 100644
--- a/misc/porteasy/Makefile
+++ b/misc/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.6.2
+PORTVERSION= 2.6.3
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/misc/porteasy/src/porteasy.pl b/misc/porteasy/src/porteasy.pl
index 2c773e6d75b2..115efa23eaa4 100644
--- a/misc/porteasy/src/porteasy.pl
+++ b/misc/porteasy/src/porteasy.pl
@@ -33,7 +33,7 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.6.2";
+my $VERSION = "2.6.3";
my $COPYRIGHT = "Copyright (c) 2000 Dag-Erling Smørgrav. All rights reserved.";
# Constants
@@ -476,7 +476,7 @@ sub find_master($) {
while (<FILE>) {
if (/^(?:MAIN|MASTER)DIR\s*=\s*(\S+)\s*$/) {
$master = $1;
- } elsif (/^\.?include \"([^\"]+)\/Makefile\"\s*$/) {
+ } elsif (/^\.?include \"([^\"]+)\/Makefile(?:[^\/\"]*)\"\s*$/) {
$master = $1;
}
if (defined($master)) {