aboutsummaryrefslogtreecommitdiffstats
path: root/misc/posixtestsuite
diff options
context:
space:
mode:
authorphantom <phantom@FreeBSD.org>2003-12-16 14:57:33 +0800
committerphantom <phantom@FreeBSD.org>2003-12-16 14:57:33 +0800
commit6685f6576a22242de020abaa7285539e12a934e2 (patch)
tree5ea7384bd84b5df33e6851ff3da4df85531f1d4f /misc/posixtestsuite
parenta4c724f001aab7722cebcead55b3bfcb17885312 (diff)
downloadfreebsd-ports-gnome-6685f6576a22242de020abaa7285539e12a934e2.tar.gz
freebsd-ports-gnome-6685f6576a22242de020abaa7285539e12a934e2.tar.zst
freebsd-ports-gnome-6685f6576a22242de020abaa7285539e12a934e2.zip
Some style changes.
Submitted by: osa (mostly)
Diffstat (limited to 'misc/posixtestsuite')
-rw-r--r--misc/posixtestsuite/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/misc/posixtestsuite/Makefile b/misc/posixtestsuite/Makefile
index 082acbe8bfc5..fd47350a878f 100644
--- a/misc/posixtestsuite/Makefile
+++ b/misc/posixtestsuite/Makefile
@@ -16,7 +16,6 @@ COMMENT= Open POSIX Test Suite
WRKSRC= ${WRKDIR}/posixtestsuite
-NO_CONFIGURE= YES
NO_BUILD= YES
NO_INSTALL= YES
NO_PACKAGE= "Nothing to package"
@@ -73,18 +72,18 @@ help: pre-everything
aclean: all
@${ECHO} "Cleaning tests tree..."
- -@(cd ${WRKSRC} && rm -f ${RUN_RESULT} && gmake clean)
+ -@(cd ${WRKSRC} && ${RM} -f ${RUN_RESULT} && ${GMAKE} clean)
rerun: all
.if defined(WITH_THRLIB)
- echo ${THRLIB} > ${WRKSRC}/LDFLAGS
+ @${ECHO} ${THRLIB} > ${WRKSRC}/LDFLAGS
.endif
.if empty(THRLIB)
@${ECHO} "Running tests (against -lc) ..."
.else
@${ECHO} "Running tests (against ${THRLIB}) ..."
.endif
- @(cd ${WRKSRC} && gmake all) ${THEPIPE} ${RUN_RESULT}
+ @(cd ${WRKSRC} && ${GMAKE} all) ${THEPIPE} ${RUN_RESULT}
@${ECHO} ""
@${ECHO} "Run output is stored into following files:"
@${ECHO} " * short version: ${RUN_RESULT}"
@@ -96,6 +95,6 @@ regression: run
@${ECHO} "Show regression log..."
@(cd ${WRKSRC} && diff -u ${FILESDIR}/${REGR_LOG} ${RUN_RESULT}) > ${LOCAL_REGR_LOG}
@[ -z ${LOCAL_REGR_LOG ] || ( ${ECHO} "No regression detected"; exit 0 )
- @${ECHO} "Regression log stored at ${LOCAL_REGR_LOG}
+ @${ECHO} "Regression log stored at ${LOCAL_REGR_LOG}"
.include <bsd.port.post.mk>