aboutsummaryrefslogtreecommitdiffstats
path: root/misc/py-osd/Makefile
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-04-06 01:17:04 +0800
committernovel <novel@FreeBSD.org>2005-04-06 01:17:04 +0800
commitbf00385aecc580fd7f56c738058015fcf08164b6 (patch)
tree36f027d9108edf5e9a94b45441702fe7e4cfaaf6 /misc/py-osd/Makefile
parent684a8ccb3ef290a4ddcfe01366a9aef895b5d08a (diff)
downloadfreebsd-ports-gnome-bf00385aecc580fd7f56c738058015fcf08164b6.tar.gz
freebsd-ports-gnome-bf00385aecc580fd7f56c738058015fcf08164b6.tar.zst
freebsd-ports-gnome-bf00385aecc580fd7f56c738058015fcf08164b6.zip
- use the original extension name "pyosd", not "osd"
- install docs PR: 78121 Submitted by: novel Approved by: maintainer timeout
Diffstat (limited to 'misc/py-osd/Makefile')
-rw-r--r--misc/py-osd/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/misc/py-osd/Makefile b/misc/py-osd/Makefile
index 07408b16c729..9ed8800cd9f1 100644
--- a/misc/py-osd/Makefile
+++ b/misc/py-osd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= osd
PORTVERSION= 0.2.12
+PORTREVISION= 1
CATEGORIES= misc python
MASTER_SITES= http://repose.cx/pyosd/ \
http://damien.kangaweb.com/moving/stuff/pyosd/
@@ -23,10 +24,18 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_REINPLACE= yes
+PORTDOCS= AUTHORS ChangeLog ChangeLog.old README README.daemon pyosd.html
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
post-patch:
- ${REINPLACE_CMD} -e 's;_X11BASE_;${X11BASE};g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's;_X11BASE_;${X11BASE};g' ${WRKSRC}/setup.py
-post-extract:
- @${MV} ${WRKSRC}/pyosd ${WRKSRC}/osd
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>