aboutsummaryrefslogtreecommitdiffstats
path: root/misc/py-osd/files
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-31 21:52:13 +0800
committerpav <pav@FreeBSD.org>2004-03-31 21:52:13 +0800
commit9ffba5d84046e026777cc8748d1fa48c8a30805b (patch)
treeba5b07f3db6c2d69929894e8db9a6c26896ab665 /misc/py-osd/files
parent0e7feb775ab6b4997e6abde00eb23b18dfd428ad (diff)
downloadfreebsd-ports-gnome-9ffba5d84046e026777cc8748d1fa48c8a30805b.tar.gz
freebsd-ports-gnome-9ffba5d84046e026777cc8748d1fa48c8a30805b.tar.zst
freebsd-ports-gnome-9ffba5d84046e026777cc8748d1fa48c8a30805b.zip
- Update to 0.2.9
- Transfer maintainership to submitter PR: ports/64916 Submitted by: Stefan Grundmann <sg-sendpr@waset.de> Approved by: old maintainer
Diffstat (limited to 'misc/py-osd/files')
-rw-r--r--misc/py-osd/files/patch-aa69
1 files changed, 57 insertions, 12 deletions
diff --git a/misc/py-osd/files/patch-aa b/misc/py-osd/files/patch-aa
index 4cfcd88d8f7a..158bd1a6f505 100644
--- a/misc/py-osd/files/patch-aa
+++ b/misc/py-osd/files/patch-aa
@@ -1,23 +1,68 @@
---- setup.py.orig Sat Nov 23 22:17:59 2002
-+++ setup.py Sat Aug 9 10:11:17 2003
-@@ -2,15 +2,16 @@
-
- from distutils.core import setup, Extension
-
--setup (name = "pyosd",
-+setup (name = "osd",
- version = "0.2.6",
- description = "Python wrapper for libosd",
+--- setup.py.orig Mon Feb 23 05:43:05 2004
++++ setup.py Tue Mar 30 03:11:16 2004
+@@ -8,9 +8,11 @@
url = "http://repose.cx/pyosd/",
author = "Damien Elmes",
author_email = "pyosd@repose.cx",
- packages = ['pyosd'],
-+ include_dirs = ['/usr/X11R6/include'],
++ include_dirs = ['_X11BASE_/include'],
+ packages = ['osd'],
ext_modules = \
- [Extension("_pyosd", ["_pyosd.c"],
- libraries=["xosd"])]
+ [Extension("_osd", ["_pyosd.c"],
-+ library_dirs = ['/usr/X11R6/lib'], libraries=["xosd"])]
++ libraries=["xosd"],
++ library_dirs = ['_X11BASE_/lib'])]
)
+--- osd/__init__.py.orig Mon Mar 1 06:17:23 2004
++++ osd/__init__.py Tue Mar 30 03:11:16 2004
+@@ -26,7 +26,7 @@
+ fonts or colours across the screen.
+ '''
+
+-import _pyosd
++import _osd as _pyosd
+ import re
+ import string
+
+@@ -44,7 +44,7 @@
+
+ error = _pyosd.error
+
+-default_font="-*-helvetica-medium-r-normal-*-*-360-*-*-p-*-*-*"
++default_font="-*-helvetica-medium-r-normal-*-*-240-*-*-p-*-*-*"
+
+ class osd:
+ """ osd is a class used to create an object which can display messages on
+--- osd/daemon.py.orig Mon Jan 26 02:14:01 2004
++++ osd/daemon.py Tue Mar 30 03:11:16 2004
+@@ -37,8 +37,8 @@
+ """
+
+ import os
+-import pyosd
+-import pyosd.daemon
++import osd as pyosd
++import osd.daemon
+ import sys
+ import string
+
+--- _pyosd.c.orig Mon Mar 1 06:16:05 2004
++++ _pyosd.c Tue Mar 30 03:11:16 2004
+@@ -73,13 +73,13 @@
+ };
+
+ void
+-init_pyosd(void)
++init_osd(void)
+ {
+ PyObject *self;
+ PyObject *dict;
+
+ // create the module and add the functions
+- self = Py_InitModule("_pyosd", pyosd_methods);
++ self = Py_InitModule("_osd", pyosd_methods);
+
+ // init custom exception
+ dict = PyModule_GetDict(self);