aboutsummaryrefslogtreecommitdiffstats
path: root/misc/py-pexpect
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-12-26 18:39:19 +0800
committerwg <wg@FreeBSD.org>2013-12-26 18:39:19 +0800
commite9c96e062d8d46f13b05606142daba0e8658cfc4 (patch)
tree268c214072807e5ddfffe6cb18bc205722b0002d /misc/py-pexpect
parent6acf6974f2aad0beabd7533483c4cb9024a1e91c (diff)
downloadfreebsd-ports-gnome-e9c96e062d8d46f13b05606142daba0e8658cfc4.tar.gz
freebsd-ports-gnome-e9c96e062d8d46f13b05606142daba0e8658cfc4.tar.zst
freebsd-ports-gnome-e9c96e062d8d46f13b05606142daba0e8658cfc4.zip
misc/py-pexpect: update to 3.0 and add license
Diffstat (limited to 'misc/py-pexpect')
-rw-r--r--misc/py-pexpect/Makefile5
-rw-r--r--misc/py-pexpect/distinfo4
-rw-r--r--misc/py-pexpect/files/patch-pexpect-__init__.py14
-rw-r--r--misc/py-pexpect/files/patch-pexpect.py21
4 files changed, 19 insertions, 25 deletions
diff --git a/misc/py-pexpect/Makefile b/misc/py-pexpect/Makefile
index cf15482443de..cc96a7129ab2 100644
--- a/misc/py-pexpect/Makefile
+++ b/misc/py-pexpect/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pexpect
-PORTVERSION= 2.4
-PORTREVISION= 1
+PORTVERSION= 3.0
CATEGORIES= misc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +10,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wg@FreeBSD.org
COMMENT= Pure Python Expect-like module
+LICENSE= ISCL
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
diff --git a/misc/py-pexpect/distinfo b/misc/py-pexpect/distinfo
index 85ae1b3fcd74..e3f4570e8940 100644
--- a/misc/py-pexpect/distinfo
+++ b/misc/py-pexpect/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pexpect-2.4.tar.gz) = 43c788f59dcf4bed677fd0b16891787dbf747e210ffedb6e90156fbbbd4d3b7b
-SIZE (pexpect-2.4.tar.gz) = 113251
+SHA256 (pexpect-3.0.tar.gz) = 1d6cee0fa5ab212f9ddac9852bab0df5fff11a173ed1bfde9346d5c8aa42d14c
+SIZE (pexpect-3.0.tar.gz) = 146662
diff --git a/misc/py-pexpect/files/patch-pexpect-__init__.py b/misc/py-pexpect/files/patch-pexpect-__init__.py
new file mode 100644
index 000000000000..425326bbfac0
--- /dev/null
+++ b/misc/py-pexpect/files/patch-pexpect-__init__.py
@@ -0,0 +1,14 @@
+--- pexpect/__init__.py.orig 2013-11-11 17:58:03.000000000 +0000
++++ pexpect/__init__.py 2013-12-26 08:28:18.423632870 +0000
+@@ -1558,10 +1558,7 @@
+ # TIOCSWINSZ and they don't have a truncate problem.
+ # Newer versions of Linux have totally different values for TIOCSWINSZ.
+ # Note that this fix is a hack.
+- TIOCSWINSZ = getattr(termios, 'TIOCSWINSZ', -2146929561)
+- if TIOCSWINSZ == 2148037735:
+- # Same bits, but with sign.
+- TIOCSWINSZ = -2146929561
++ TIOCSWINSZ = getattr(termios, 'TIOCSWINSZ', 2148037735L)
+ # Note, assume ws_xpixel and ws_ypixel are zero.
+ s = struct.pack('HHHH', rows, cols, 0, 0)
+ fcntl.ioctl(self.fileno(), TIOCSWINSZ, s)
diff --git a/misc/py-pexpect/files/patch-pexpect.py b/misc/py-pexpect/files/patch-pexpect.py
deleted file mode 100644
index c7b56520c47f..000000000000
--- a/misc/py-pexpect/files/patch-pexpect.py
+++ /dev/null
@@ -1,21 +0,0 @@
---- pexpect.py.orig 2008-08-18 18:27:05.000000000 -0400
-+++ pexpect.py 2010-06-24 15:15:26.000000000 -0400
-@@ -1437,17 +1437,7 @@
- applications like vi or curses -- applications that respond to the
- SIGWINCH signal. """
-
-- # Check for buggy platforms. Some Python versions on some platforms
-- # (notably OSF1 Alpha and RedHat 7.1) truncate the value for
-- # termios.TIOCSWINSZ. It is not clear why this happens.
-- # These platforms don't seem to handle the signed int very well;
-- # yet other platforms like OpenBSD have a large negative value for
-- # TIOCSWINSZ and they don't have a truncate problem.
-- # Newer versions of Linux have totally different values for TIOCSWINSZ.
-- # Note that this fix is a hack.
-- TIOCSWINSZ = getattr(termios, 'TIOCSWINSZ', -2146929561)
-- if TIOCSWINSZ == 2148037735L: # L is not required in Python >= 2.2.
-- TIOCSWINSZ = -2146929561 # Same bits, but with sign.
-+ TIOCSWINSZ = getattr(termios, 'TIOCSWINSZ', 2148037735L)
- # Note, assume ws_xpixel and ws_ypixel are zero.
- s = struct.pack('HHHH', r, c, 0, 0)
- fcntl.ioctl(self.fileno(), TIOCSWINSZ, s)