aboutsummaryrefslogtreecommitdiffstats
path: root/misc/py-pyprind
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-06-30 17:13:59 +0800
committerkoobs <koobs@FreeBSD.org>2016-06-30 17:13:59 +0800
commitd5bc4da4222c6c9f2dffe532cc6fd89643766305 (patch)
treef1d9a07177722f4c24c18dac97727376b8e56c3f /misc/py-pyprind
parent3d216371fc6c26821f0c8bd3021ef2c6dda7f83b (diff)
downloadfreebsd-ports-gnome-d5bc4da4222c6c9f2dffe532cc6fd89643766305.tar.gz
freebsd-ports-gnome-d5bc4da4222c6c9f2dffe532cc6fd89643766305.tar.zst
freebsd-ports-gnome-d5bc4da4222c6c9f2dffe532cc6fd89643766305.zip
[NEW] misc/py-pyprind: Python Progress Bar and Percent Indicator Utility
The PyPrind (Python Progress Indicator) module provides a progress bar and a percentage indicator object that let you track the progress of a loop structure or other iterative computation. Typical applications include the processing of large data sets to provide an intuitive estimate at runtime about the progress of the computation. WWW: https://www.github.com/rasbt/pyprind PR: 207758 Submitted by: Neel Chauhan <neel neelc org>
Diffstat (limited to 'misc/py-pyprind')
-rw-r--r--misc/py-pyprind/Makefile33
-rw-r--r--misc/py-pyprind/distinfo3
-rw-r--r--misc/py-pyprind/files/patch-setup.py10
-rw-r--r--misc/py-pyprind/pkg-descr7
4 files changed, 53 insertions, 0 deletions
diff --git a/misc/py-pyprind/Makefile b/misc/py-pyprind/Makefile
new file mode 100644
index 000000000000..82e8095eac9f
--- /dev/null
+++ b/misc/py-pyprind/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= pyprind
+PORTVERSION= 2.9.8
+DISTVERSIONPREFIX= v
+CATEGORIES= misc
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyPrind-${PORTVERSION}
+
+MAINTAINER= neel@neelc.org
+COMMENT= Python Progress Bar and Percent Indicator Utility
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=0.5.1:sysutils/py-psutil
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= PSUTIL
+
+PSUTIL_DESC= Support monitoring CPU and memory usage
+PSUTIL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>=0.5.1:sysutils/py-psutil
+
+test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/misc/py-pyprind/distinfo b/misc/py-pyprind/distinfo
new file mode 100644
index 000000000000..b18b4d661ef8
--- /dev/null
+++ b/misc/py-pyprind/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465130692
+SHA256 (PyPrind-2.9.8.tar.gz) = f07dd20388a0d21838112deeb70b1705a9ebfeb8859c5741433126e4efb439b2
+SIZE (PyPrind-2.9.8.tar.gz) = 10154
diff --git a/misc/py-pyprind/files/patch-setup.py b/misc/py-pyprind/files/patch-setup.py
new file mode 100644
index 000000000000..05a5b6ba64c2
--- /dev/null
+++ b/misc/py-pyprind/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2016-04-14 15:46:12 UTC
++++ setup.py
+@@ -39,6 +39,7 @@ setup(name='PyPrind',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Environment :: Console'],
++ test_suite = "nose.collector",
+ long_description="""
+
+ The PyPrind (Python Progress Indicator) module provides a progress
diff --git a/misc/py-pyprind/pkg-descr b/misc/py-pyprind/pkg-descr
new file mode 100644
index 000000000000..4cf950480854
--- /dev/null
+++ b/misc/py-pyprind/pkg-descr
@@ -0,0 +1,7 @@
+The PyPrind (Python Progress Indicator) module provides a progress bar
+and a percentage indicator object that let you track the progress of a
+loop structure or other iterative computation. Typical applications
+include the processing of large data sets to provide an intuitive
+estimate at runtime about the progress of the computation.
+
+WWW: https://www.github.com/rasbt/pyprind