aboutsummaryrefslogtreecommitdiffstats
path: root/misc/py-qt4-demo/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-03-20 20:40:00 +0800
committermiwi <miwi@FreeBSD.org>2008-03-20 20:40:00 +0800
commit2e75c82c4062429313471e76881d62c67b3af4cf (patch)
treefc43e139a19304e7e6535136855f93ae69d42727 /misc/py-qt4-demo/Makefile
parentb54be1db2c3c1fae82942fb1d95ad988e29e0bd1 (diff)
downloadfreebsd-ports-gnome-2e75c82c4062429313471e76881d62c67b3af4cf.tar.gz
freebsd-ports-gnome-2e75c82c4062429313471e76881d62c67b3af4cf.tar.zst
freebsd-ports-gnome-2e75c82c4062429313471e76881d62c67b3af4cf.zip
- Update to 4.3.3
- Configure.py now has a flag to specify component, patch is now simpler - Update qscintilla2 so version where used - Use bsd.pyqt.mk Submitted by: Danny Pansters <danny@ricin.com> (maintainer via private mail)
Diffstat (limited to 'misc/py-qt4-demo/Makefile')
-rw-r--r--misc/py-qt4-demo/Makefile43
1 files changed, 22 insertions, 21 deletions
diff --git a/misc/py-qt4-demo/Makefile b/misc/py-qt4-demo/Makefile
index 8e55ff432c69..9736c55392b5 100644
--- a/misc/py-qt4-demo/Makefile
+++ b/misc/py-qt4-demo/Makefile
@@ -5,16 +5,16 @@
# $FreeBSD$
PORTNAME= demo
-PORTVERSION= 4.3.1
-PORTREVISION= # zero
+PORTVERSION= ${PYQT4_VERSION}
+PORTREVISION= 1
+
CATEGORIES= misc devel python
-MASTER_SITES= http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/ \
- http://freebsd.ricin.com/ports/distfiles/
+MASTER_SITES= ${MASTER_SITES_PYQT4}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
-DISTNAME= PyQt-x11-gpl-${PORTVERSION}
+DISTNAME= ${PYQT4_DISTNAME}
-MAINTAINER= danny@ricin.com
-COMMENT= Python bindings for the Qt4 toolkit, demo and other examples
+MAINTAINER= ${PYQT_MAINTAINER}
+COMMENT= Python bindings for the Qt4 toolkit, Qt demo and examples
USE_PYTHON= yes
@@ -23,24 +23,25 @@ OPTIONS= PYQT4 "Install any missing PyQt4 components" on
OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
EXAMPLESDIR= ${PREFIX}/share/examples/py-qt4
+.include "../../devel/py-sip/files/bsd.pyqt.mk"
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_PYQT4)
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt4/QtCore.so:${PORTSDIR}/devel/py-qt4-core \
- ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \
- ${PYTHON_SITELIBDIR}/PyQt4/QtNetwork.so:${PORTSDIR}/net/py-qt4-network \
- ${PYTHON_SITELIBDIR}/PyQt4/QtXml.so:${PORTSDIR}/textproc/py-qt4-xml \
- ${PYTHON_SITELIBDIR}/PyQt4/QtAssistant.so:${PORTSDIR}/devel/py-qt4-assistant \
- ${PYTHON_SITELIBDIR}/PyQt4/QtOpenGL.so:${PORTSDIR}/x11/py-qt4-opengl \
- ${PYTHON_SITELIBDIR}/PyQt4/QtScript.so:${PORTSDIR}/devel/py-qt4-script \
- ${PYTHON_SITELIBDIR}/PyQt4/QtSql.so:${PORTSDIR}/databases/py-qt4-sql \
- ${PYTHON_SITELIBDIR}/PyQt4/QtSvg.so:${PORTSDIR}/graphics/py-qt4-svg \
- ${PYTHON_SITELIBDIR}/PyQt4/QtTest.so:${PORTSDIR}/devel/py-qt4-test \
- ${PYTHON_SITELIBDIR}/PyQt4/QtDesigner.so:${PORTSDIR}/devel/py-qt4-designer \
- ${LOCALBASE}/lib/qt4/plugins/designer/libpythonplugin.so:${PORTSDIR}/devel/py-qt4-designerplugin \
- ${PYTHON_SITELIBDIR}/dbus/mainloop/qt.so:${PORTSDIR}/devel/py-qt4-dbus
+RUN_DEPENDS= ${PKGNAMEPREFIX}core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-core \
+ ${PKGNAMEPREFIX}gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-qt4-gui \
+ ${PKGNAMEPREFIX}network>=${PYQT4_VERSION}:${PORTSDIR}/net/py-qt4-network \
+ ${PKGNAMEPREFIX}xml>=${PYQT4_VERSION}:${PORTSDIR}/textproc/py-qt4-xml \
+ ${PKGNAMEPREFIX}assistant>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-assistant \
+ ${PKGNAMEPREFIX}opengl>=${PYQT4_VERSION}:${PORTSDIR}/x11/py-qt4-opengl \
+ ${PKGNAMEPREFIX}script>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-script \
+ ${PKGNAMEPREFIX}sql>=${PYQT4_VERSION}:${PORTSDIR}/databases/py-qt4-sql \
+ ${PKGNAMEPREFIX}svg>=${PYQT4_VERSION}:${PORTSDIR}/graphics/py-qt4-svg \
+ ${PKGNAMEPREFIX}test>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-test \
+ ${PKGNAMEPREFIX}designer>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-designer \
+ ${PKGNAMEPREFIX}designerplugin>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-designerplugin \
+ ${PKGNAMEPREFIX}dbus>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-dbus
.if !defined(NOPORTDOCS)
-RUN_DEPENDS+= ${LOCALBASE}/share/doc/py-qt4/pyqt4ref.html:${PORTSDIR}/misc/py-qt4-doc
+RUN_DEPENDS+= ${PKGNAMEPREFIX}doc>=${PYQT4_VERSION}:${PORTSDIR}/misc/py-qt4-doc
.endif
.endif