aboutsummaryrefslogtreecommitdiffstats
path: root/misc/py-yolk
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2013-08-14 22:00:20 +0800
committernivit <nivit@FreeBSD.org>2013-08-14 22:00:20 +0800
commit0a76682ee52075d4f07e8261ceca005002d2f378 (patch)
treeeab831a0a8876e370122ce7462642834288f52ce /misc/py-yolk
parentb60ceea759cadfcce9032f0acd7bb89e2c0af67e (diff)
downloadfreebsd-ports-gnome-0a76682ee52075d4f07e8261ceca005002d2f378.tar.gz
freebsd-ports-gnome-0a76682ee52075d4f07e8261ceca005002d2f378.tar.zst
freebsd-ports-gnome-0a76682ee52075d4f07e8261ceca005002d2f378.zip
- Update to 0.4.3
- Trim Makefile header - Remove dead link from MASTER_SITES - Remove indefinite article from COMMENT - Add LICENSE (BSD) - Convert to the new options framework - Update WWW field in pkg-descr Build details: http://goo.gl/l5Fmwu
Diffstat (limited to 'misc/py-yolk')
-rw-r--r--misc/py-yolk/Makefile49
-rw-r--r--misc/py-yolk/distinfo4
-rw-r--r--misc/py-yolk/pkg-descr2
3 files changed, 29 insertions, 26 deletions
diff --git a/misc/py-yolk/Makefile b/misc/py-yolk/Makefile
index b549405ff273..7d1fabc139c3 100644
--- a/misc/py-yolk/Makefile
+++ b/misc/py-yolk/Makefile
@@ -1,47 +1,50 @@
-# New ports collection makefile for: yolk
-# Date created: 2007-03-11
-# Whom: Nicola Vitale <nivit@FreeBSD.org>
-#
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= yolk
-PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTVERSION= 0.4.3
+PORTREVISION= 0
CATEGORIES= misc python
-MASTER_SITES= ${MASTER_SITE_CHEESESHOP} \
- http://nivi.interfree.it/distfiles/${PORTNAME}/
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
MASTER_SITE_SUBDIR= source/y/${PORTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
-COMMENT= A Python tool for listing packages installed by setuptools
+COMMENT= Command-line tool for querying PyPI and Python packages installed
-USE_PYTHON= 2.6+
-USE_PYDISTUTILS= easy_install
+LICENSE= BSD
+
+OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
+OPTIONS_DEFINE= EXAMPLES MANPAGES
+OPTIONS_DEFAULT= MANPAGES
-.if !defined (NO_INSTALL_MANPAGES)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMANPAGES}
MAN1= ${PORTNAME}.1
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} == 271 || ${PYTHON_REL} == 320
-IGNORE= does not work with ${PYTHON_VERSION} (see http://goo.gl/SZpDN)
+.if ${PORT_OPTIONS:MEXAMPLES}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
.endif
+USE_PYTHON= 2.6-2.7
+USE_PYDISTUTILS= easy_install
+
post-install:
-.if !defined (NO_INSTALL_MANPAGES)
- @${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
+.if ${PORT_OPTIONS:MMANPAGES}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
.endif
-.if !defined (NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@cd ${WRKSRC}/examples && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} ";"
- @cd ${WRKSRC}/examples && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} ";"
+ cd ${WRKSRC}/examples && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} ";"
.endif
-.if !defined (NOPORTEXAMPLES)
-EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} == 271 || ${PYTHON_REL} == 320
+IGNORE= does not work with ${PYTHON_VERSION} (see http://goo.gl/SZpDN)
.endif
.include <bsd.port.post.mk>
diff --git a/misc/py-yolk/distinfo b/misc/py-yolk/distinfo
index b8018141245e..c1c79f17f4be 100644
--- a/misc/py-yolk/distinfo
+++ b/misc/py-yolk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (yolk-0.4.1.tar.gz) = f03d9ebe2fa67aa210868312a474d949d26732b743aeece970e06f02ff740212
-SIZE (yolk-0.4.1.tar.gz) = 80537
+SHA256 (yolk-0.4.3.tar.gz) = 1c07eb4001dc133c08e66e38c5d58faa7616ae804f8d0ab02dd44a1044e7ddb8
+SIZE (yolk-0.4.3.tar.gz) = 86100
diff --git a/misc/py-yolk/pkg-descr b/misc/py-yolk/pkg-descr
index 47ca5ea8a53e..fc5cb93bae66 100644
--- a/misc/py-yolk/pkg-descr
+++ b/misc/py-yolk/pkg-descr
@@ -2,4 +2,4 @@ Yolk is a Python library and command-line tool for obtaining information
about packages installed by setuptools and packages on PyPI (Python Package
Index a.k.a. The Cheese Shop).
-WWW: http://tools.assembla.com/yolk/
+WWW: https://pypi.python.org/pypi/yolk